My Calendar
[resolved] Fatal error: Maximum execution time of 30 seconds exceeded in (9 posts)

  1. skeeterz71
    Posted 3 years ago #

    So I got this error now when trying to load my site...
    Fatal error: Maximum execution time of 30 seconds exceeded in /home/..../public_html/....../wp-includes/option.php on line 88.

    I have a ton of events. I sure hope there is something that can be done. I still have a lot of events left to add.

    I contacted hostgator and this is what they say:

    Unfortunately, this is a custom plugin issue and not an actual issue with our servers. Because of this your issue is out of the scope of support I am able to provide you. I do apologize for the inconvenience, but I am bound to our terms of service in this case. I highly suggest that you contact the plugin's developer about this issue. Is there anything else I can assist you with?


  2. Joe Dolson
    Plugin Author

    Posted 3 years ago #

    Please send me a support request. This kind of problem usually indicates a misconfigured recurring event, but I can't be very specific without seeing your events.

  3. skeeterz71
    Posted 3 years ago #

    What I did was delete the event that caused it. I had set up an event with two instances, same recurring meeting at two different times.

    Then I set those meetings up separately instead of using the group function that allows you to set up one meeting and different instances of that meeting.

    That fixed the problem.

  4. skeeterz71
    Posted 3 years ago #

    I just wanted to give you some additional details. As stated it was a meeting with more than one instance and the calendar has a provision for setting up a meeting once and providing different dates and times that recur.

    This particular meeting happens twice a day and that is why I think the errors occurred. I'm guessing the calendar isn't designed to have the same meeting happen twice on the same date and recur daily. It times out instead:) Setting up the meetings as two separate meetings fixed the problem.

  5. skeeterz71
    Posted 3 years ago #

    I'm running into this same issue again except this time the dates are different though the time of day is the same. sigh. If I have to set up meetings separately like this, organization is going to be a mess.

  6. Joe Dolson
    Plugin Author

    Posted 3 years ago #

    This really shouldn't be happening; how are you specifically setting up the events? What are the start/end dates/times and recurring pattern?

    I suggest submitting a support request; it may be most efficient if I can take a look at what you're doing. This could be a bug, but I don't know enough about what you're doing to investigate it in any way.

  7. skeeterz71
    Posted 3 years ago #

    Thanks Joe,

    I've already set each up as it's own.

    Here is what I was doing. Example:
    5 meetings Monday through Friday. 4 were at 7:pm and one at 7:30 pm. Recur forever
    When I would setup one event instance, and then "add another instance x4 with the same times on their respective dates and x1 for the different time, then set to recur weekly, it worked for the first 3 or so events I setup.

    I tried 3 or for other times to set up events this way and it would time out.

    I deleted all grouped events and set them up separately. That fixed the time out issue and appears to have sped up the loading of the calendar as well.

    I hope this makes sense.

  8. Joe Dolson
    Plugin Author

    Posted 3 years ago #

    Did you set end dates for those events? What dates did you set, if so?

    I've done this many times, and never had trouble; so I'm looking to see what specific characteristics these have.

  9. skeeterz71
    Posted 3 years ago #

    I didn't set an end date , just set to recur. I'm about to set up another calendar. I'll try it again and submit a support ticket if I have the same issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • My Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.