WordPress.org

Support

Support » Plugins and Hacks » WPDBSpringClean » [Resolved] Fatal Error: Maximum execution time of 30 seconds exceeded

[Resolved] Fatal Error: Maximum execution time of 30 seconds exceeded

  • Hello,

    I have been trying to run this plugin but continue to get the following error:

    Fatal error: Maximum execution time of 30 seconds exceeded in wordpress\wp-content\plugins\wpdbspringclean\grepSearch.php on line 14

    I have a local installation using xampp, WordPress 3.6, and have used a fresh install of the plugin. I have also deactivated all other plugins except for this one and still it continues to have the fatal error and plugin hangs.

    Any insight would be much appreciated!

    http://wordpress.org/plugins/wpdbspringclean/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author wpsolutions

    @wpsolutions

    Hi,
    yes I am aware that for local (xampp) installs this plugin will generate a timeout error. (Not sure why at this stage but it might be something with the default xampp settings causing this).

    If you try the plugin on live a host you will find that it works as expected.

    Plugin Author wpsolutions

    @wpsolutions

    I can confirm that the problem you are seeing is definitely caused by the default xampp settings.

    To fix this, open the php.ini file from your xampp installation (I found my file here: C:\xampp\php\php.ini)

    Then just change the value of the max_execution_time parameter from 30 to 60 seconds or greater.

    thnx a lot, fixed my issues.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Fatal Error: Maximum execution time of 30 seconds exceeded’ is closed to new replies.
Skip to toolbar