Fatal error: Maximum execution time of 30 seconds AGAIN (19 posts)

  1. pixerlise
    Posted 8 years ago #

    As i can see from the support forum, a lot of people have this problem.
    I have this "Fatal error: Maximum execution time of 30 seconds..." problem on almost every php is inside these folders "wp-includes", "wp-themes", "wp-login" etc..

    I have write about ~30 articles and now i can't even watch my blog. I don't speak to get into the admins page. No waY!!!! http://www.pixelrise.gr/blog

    It seems my blog is "blocked" now and i can't do anything about it.

    Is there a solution for this?

  2. jbbrwcky
    Posted 7 years ago #

    Upgraded a client's blog to WordPress 2.5 and now getting this very issue (they weren't beforehand):

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/site/www/site.com/wp-includes/post.php on line 1272

    Is this something that more people are experiencing since 2.5?

  3. VolCh
    Posted 7 years ago #

    I am getting

    Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/wordpress25/wp-includes/classes.php on line 422 (line can be +-5)

    during output 1000+ nested caregories (3 levels of depth) after upgrade. When categories are not nested (set wp_term_taxonomy.parent=0 for all) it taken few seconds on localhost. In WP 2.3 all was OK with nested

  4. thepsychicpilot
    Posted 7 years ago #

    I've noticed over the last couple of days that this error has been happening when I access my dashboard, though I've chalked it up to a poor connection at home. However, today at work where connectivity is never an issue, I've been getting this error all day long. It happens when I go directly to my main URL, to the wp-admin, wp-admin/themes, etc. At this point, I can't even get into my admin to post or investigate anything. I haven't made any modifications to my theme or site since I noticed this happening, so I'm at a loss as to what could be causing it.

    Is it my site or could it be my host causing a time out?

    Any help is appreciated.


  5. lapital
    Posted 7 years ago #

    I had encoutered this problem when I post an article in a title of posted article.
    when I post the article in a new title, the problem did not occur anymore.

  6. nepalhk
    Posted 7 years ago #

    Hi Friends!
    I also had the same problem which was [Fatal error: Maximum execution time of 30 seconds exceeded in
    /home/nepalhk/domains/nepal.hk/public_html/wp-includes/post.php on line 1272], it occured when I upgraded wp to 2.5. Sometimes, I had to post dozens of articles together and because of the perticular error, I get stuck on one or two or three posts for a long time and it couldn't evenget published.
    But, I don't know what exactly the prblms there, I somehow managed to pass that through. If you happened to have this error, just go bak to the edit page and change a bit on your post's title, then you are off.
    Prakash K.C.

  7. Jeffrey04
    Posted 7 years ago #

    @nepalhk thanks for the information. I am suspecting the the problem is caused by redundant post title. Gotta post a feature request/bug report so that wordpress returns a more helpful error message when an article with a redundant title is posted.

  8. CaiTLiN_CoRR
    Posted 7 years ago #

    It IS because of the redundant post title. I had the same problem and solved it by changing the title!

  9. 67comet
    Posted 7 years ago #

    This issue is ongoing with me as well. When I try to make a new post I get this error:
    Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/jedisteiger/pages/wordpress/wp-includes/plugin.php on line 274

    It happens on ALL the wordpress blogs I've got on my server (about 11). I've added php.ini changes to 600 seconds, and checked out Apache for a time limit, and nothing unusual. All the sites work perfectly, except we can not post a blog.

    Help? I've also re-installed the OS with nothing special (Ubuntu 8.04 Server Edition). Reloaded all the MySQL and web site directories and files back ups. So I'm "assuming" it is in either the MySQL databases, or WordPress files that there is an error.

    Any suggestions on where to go look next?

    Thank you,

  10. MichaelH
    Posted 7 years ago #

    67comet - might list your host, web-server software, web-server version, PHP version, and MySQL version

  11. 67comet
    Posted 7 years ago #

    Sorry for the delay, been pretty busy.

    I installed a fresh directory of wordpress, new MySQL database and it works fine. I've got so many users with full sites now I really would rather NOT tell them "start over".

    Here is my data:
    CPU AMD Sempron(tm) Processor 3000+
    1024mb RAM
    250gig www/hdd
    40gig OS/hdd
    Ubuntu Server Edition (8.04)

    WP 2.5.1
    Apache 2.2.8
    MySQL 5.0.51
    PHP 5?

    I'm sure it is probably a simple syntax error between my restored copies of MySQL and what was in the wordpress directory for all the sites (each site has their own wordpress directory with in their own web directories).

    Hope this helps,

  12. distobj
    Posted 7 years ago #

    I just ran into this problem last night too, on line 274 of plugin.php. I encountered it during an import of a small WXR file. It always stops at the same point in the file, and always on that line in plugin.php.

    I don't know where it's getting the "60 seconds" value from though - I updated php.ini temporarily and increased the value to 600, but it still complains about 60. Weird.

  13. voxconscientia
    Posted 7 years ago #

    Me too; and I have a client beating my door down to finish their migration. What is this? I uninstalled Google Sitemaps to no avail.

  14. 67comet
    Posted 7 years ago #

    I've still got the error. If I add a new database to MySQL and drop a fresh WordPress directory in it all works as advertised. This leads me to think it might be something with MySQL and the way it was backed up and restored.

    I did a temp fix to all my users by giving them green wordpress starting points, but I keep their original wordpress directories untouched but accessible via the www to keep testing things.

    I hit up the IRC rooms and they suggested I kill all my plugins, did that to no help. Tried to clean out all tabled in MySQL and that didn't help (lost all the blogs so I had to reload them all from back up).

    Since ALL the sites have the exact same error it leads me to MySQL or something that changed in WP in between the backup and the reinstall.

    Anyone got anywhere else to start looking?

    Thank you,

  15. 67comet
    Posted 7 years ago #

    Update .. I just tried to update a previous post on my server and it works great, I just can't add a new post.

  16. Shmutt
    Posted 7 years ago #

    I solved this problem (Fatal error: Maximum execution time of 60 seconds exceeded in /home/site/www/site.com/wp-includes/plugins.php on line 274) by editing the wp-includes/functions.php in line 600.

    Originally, its: "$buf = fread( $fp, 4096 );"
    But I changed it: "$buf = fread( $fp, 16384 );"

    Works for me! However, I am not sure of the repurcussions though...

  17. Anonymous
    Posted 7 years ago #

    I give u solution for 30 seconds error.
    u go to system folder of ur system partition to looking for a text file, "php.ini".

    u search two statement with parameter in below and change it:
    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data

    at last, u restart webservice, IIS or apache, after u save the modified file.

  18. Nabber
    Posted 7 years ago #

    Can anyone explain this in laymans terms?

    I am trying to upload my imported blog.

  19. KrisMx
    Posted 7 years ago #

    Hey, I have the same error after upgrading to v2.7, does anyone has fixed this?

Topic Closed

This topic has been closed to new replies.

About this Topic