Support » Plugin: Redis Object Cache » Fatal error: Maximum execution time

  • Resolved mberto

    (@mberto)


    Hello,
    I encounter the “Fatal error: Maximum execution time xxx seconds exceeded in xxx on line xxx” problem when I save a post or a page. I tried increasing the max_execution_time parameter to 900 but it keeps timeout.

    If, on the other hand, I disable the plugin, everything works correctly.

    Redis is up and running, through the ‘redis-cli monitor’ I see all the transactions but I noticed that they are not continuous, they are paused even for a few minutes and then they restart.

    This is my “diagnostic”:

    Status: Connected
    Client: PhpRedis (v4.3.0)
    Drop-in: Valid
    Disabled: No
    Ping: +PONG
    Errors: []
    PhpRedis: 4.3.0
    Relay: Not loaded
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.3.16
    Plugin Version: 2.0.26
    Redis Version: 5.0.7
    Multisite: Yes
    Metrics: Enabled
    Metrics recorded: 1399
    Filesystem: Working
    Global Prefix: ""
    Blog Prefix: 1
    WP_REDIS_PREFIX: "--REMOVED--"
    WP_CACHE_KEY_SALT: "--REMOVED--"
    WP_REDIS_IGNORED_GROUPS: ["counts","plugins","users","userlogins","usermeta","user_meta"]
    Global Groups: [
        "blog-details",
        "blog-id-cache",
        "blog-lookup",
        "global-posts",
        "networks",
        "rss",
        "sites",
        "site-details",
        "site-lookup",
        "site-options",
        "site-transient",
        "users",
        "useremail",
        "userlogins",
        "usermeta",
        "user_meta",
        "userslugs",
        "redis-cache",
        "blog_meta",
        "sitepress_ms"
    ]
    Ignored Groups: [
        "counts",
        "plugins",
        "users",
        "userlogins",
        "usermeta",
        "user_meta",
        "WPML_ST_Package_Factory",
        "themes"
    ]
    Unflushable Groups: []
    Drop-ins: [
        "install.php v by ",
        "Redis Object Cache Drop-In v2.0.26 by Till Krüss"
    ]

    What could be the problem?

    I thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    One of your 3rd party plugins may cause an infinite loop.

    If you disable all other plugins except this one, does it work?

    Thread Starter mberto

    (@mberto)

    I deactivated all the plugins except for the ones that are required (WPML, ACF Pro) for the site to function correctly but it has not been solved.

    The problem appeared after updating the plugin to the latest version, with the previous version I never had any kind of problem.

    I’ll do other more in-depth tests and let you know.

    Thanks for the support`

    Plugin Author Till Krüss

    (@tillkruess)

    Did you figure it out?

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.