Support » Plugin: Responsive Pricing Table » Fatal Error Line 340 of rpt.php

  • Resolved harrison.lloyd

    (@harrisonlloyd)


    Parse error: syntax error, unexpected ‘[‘ in rpt.php

    I’ve ended up commenting out the entire $feature function block and that has my website back up and running. Everything was fine until updating RPT today.

    Any suggestions?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Same issue here! 🙁

    Plugin Author WP Darko

    (@spwebguy)

    On it!

    Thanks Darko!!! You the man!

    Plugin Author WP Darko

    (@spwebguy)

    Hi both,

    We’ve tested it (before releasing but also just now) and it works fine, that’s very strange. Are you using 4.3.1?

    This line caused the content of the page to disappear on some sites, which is why we patched it yesterday.

    For now you could downgrade to 4.3 (sorry about that). Could you send us a request at http://wpdarko.com/support with as many details as you can (theme used, screenshot of your pricing table admin page, URL of your pricing page)?

    We’ll take a look at it today.
    Sorry for the inconvenience caused.

    OK. My error code says that it is line 330 "if (!empty($plans['_rpt_features'])){"

    Plugin Author WP Darko

    (@spwebguy)

    We’ve received more support requests for this and are currently working on it.

    I’ll keep you updated here. Please roll back to 4.3 for now.

    Plugin Author WP Darko

    (@spwebguy)

    Thank you for this @spinmedia

    Plugin Author WP Darko

    (@spwebguy)

    @spinmedia I can’t reproduce the issue even though many of you have it, could you try using this version of the plugin and tell me if it goes back to normal?

    Download the fixed version (link removed because doesn’t work).

    Thank you for your help!

    • This reply was modified 4 years, 10 months ago by WP Darko.
    • This reply was modified 4 years, 10 months ago by WP Darko.
    Plugin Author WP Darko

    (@spwebguy)

    OK @spinmedia and @harrisonlloyd it seems that we have solved the issue.

    We released 4.3.2 that you can find now on WordPress.org (here).

    For those interested:
    It seems that (a server using) PHP 7.1.0 doesn't allow us to create arrays of data the way we did until now.

    We have been unable to test it yet and are doing this at the moment, please send some feedback if it works for you!

    Thank you.

    • This reply was modified 4 years, 10 months ago by WP Darko.

    Thanks @spwebguy

    That was really fast!

    Plugin Author WP Darko

    (@spwebguy)

    @spinmedia

    Well, I currently have no way to see if it works. Could you uninstall your current plugin, install the one that’s on WordPress.org and let me know how it goes?

    Thanks a lot to you.

    Thread Starter harrison.lloyd

    (@harrisonlloyd)

    @spwebguy

    4.3.2 fixed it for me. Thanks so much!

    edit: am using php 5.3.3

    Plugin Author WP Darko

    (@spwebguy)

    Good!

    Yeah we eventually tested it with PHP 7.1.0 and still couldn’t reproduce the issue. Glad it works though.

    We simply are setting our empty array like this:
    $var = array();
    Instead of:
    $var = [];
    And the following worked too but makes less sense:
    $var = '';

    Sorry again for the time wasted, thank you for your patience.

    Thread Starter harrison.lloyd

    (@harrisonlloyd)

    For what its worth, the theme I am using is a child theme of iThemes’ builder theme.

    My pricing table is at http://www.pivothunter.com/pricing-table/

    No time wasted, we appreciate your hard work.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fatal Error Line 340 of rpt.php’ is closed to new replies.