Support » Plugin: Postman SMTP Mailer/Email Log » Fatal error: Internal Zend error – Missing class information

  • Resolved cecilette

    (@cecilette)


    Hi, I keep randomly getting the following error on my client’s site.

    Fatal error: Internal Zend error – Missing class information for in /home/content/07/7491807/html/wp-content/plugins/postman-smtp/Postman/PostmanState.php on line 10

    I found some posts about that error with other plugins and disabled apc in php.ini (apc.enabled=0). It’s still doing it on almost every page load, though.

    https://wordpress.org/plugins/postman-smtp/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jason Hendriks

    (@jasonhendriks)

    I’ve never seen that one before. Would you please post the Diagnostic Data from the site having the problem.

    Upgrading PHP also seems to be a fix for some people.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    Ah! I read this article, Do you have any code which includes the same class multiple times with include? (which I found from here which I found from here) and it turns out I am calling PostmanState.php with a require instead of require_once.

    Would you please download and install the development version and let me know if the error is gone. https://downloads.wordpress.org/plugin/postman-smtp.zip

    cecilette

    (@cecilette)

    Here it is:

    OS: Linux p3nlhg462.shr.prod.phx3.secureserver.net 2.6.32-531.1.2.lve1.2.54.el6.nfsfixes.x86_64 #1 SMP Wed Apr 2 14:06:52 MST 2014 x86_64
    HTTP User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.124 Safari/537.36
    Platform: PHP Linux 5.2.17 / WordPress 4.2.2 en_US
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=No, allow_url_fopen=Yes, mcrypt=Yes
    WordPress Plugins: Gravity Forms, All In One WP Security, Duplicator, Gravitate Encryption, Gravity Forms Signature Add-On, Jetpack by WordPress.com, Postman SMTP
    WordPress Theme: tatetheme
    Postman Version: 1.6.22
    Postman Sender Domain: gmail.com
    Postman Transport URI|Force Email|Name: gmail_api:https:oauth2://www.googleapis.com:443|No|No
    Postman Transport Status (Configured|Ready|Connected): Yes|Yes|Yes
    Postman Deliveries (Success|Fail): 1|0
    Postman Bind (Success|Fail|Path): Yes|No|/home/content/07/7491807/html/wp-content/plugins/postman-smtp/Postman/PostmanWpMailBinder.php
    Postman TCP Timeout (Connection|Read): 10|60
    Postman Email Log (Enabled|Limit|Transcript Size): Yes|10|128
    Postman Run Mode: production
    Postman PHP LogLevel: 40000
    Postman Stealth Mode: No
    Postman File Locking (Enabled|Temp Dir): Yes | /tmp

    …I didn’t get the error when visiting the site this time, so maybe disabling apc worked and needed a bit of time to take effect? It was the recommended fix in a few other places.

    Thanks for looking into it!

    cecilette

    (@cecilette)

    Thanks Jason, I’m going to be out today but I’ll try it tonight and let you know how it goes.

    MOBYPOS

    (@mobypos)

    I’m also getting this problem, and it’s making it very difficult to do things like update plug-ins and edit pages.

    I installed the development version linked above and that does fix the error, but all Google API e-mails bounce.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    @mobypos, you’ve hijacked this thread

    all Google API e-mails bounce.

    You’ll need to give me more than that. Why are they bouncing? Bounce receipts always contain an explanation for the cause of the bounce.

    MOBYPOS

    (@mobypos)

    It’s not a traditional bounce receipt – it simply comes from ‘BOUNCE’ – ‘nobody@gmail.com’ and won’t process through Google’s servers to the recipient. The reply-to is noreply@gmail.com.

    There is nothing in the headers, and just a cryptic ‘An error occurred. Your message was not sent.’ statement placed above the original message.

    I can forward you the headers if you like.

    1.6.22 with the same configuration does not result in the ‘BOUNCE’ message from gmail’s servers, it’s only 1.6.23d.

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    You’re right. My Gmail API tester has been getting bounces since Jun 21 and I just didn’t notice.

    Turns out there is an empty Reply-To header that Gmail API obviously does not like. Fixed. You can re-download from the trunk and both issues should be gone.

    Thank-you for the bug report!

    cecilette

    (@cecilette)

    FYI Jason, I was going to try your dev version, so I removed apc.enabled=0 from php.ini so I could get the error back. The error hasn’t re-occurred since… so I didn’t use it but I’m keeping it on the back burner in case it pops up again. Thanks!

    Plugin Author Jason Hendriks

    (@jasonhendriks)

    @cecilette from what I read, this problem only occurs under when the server is under “high load”

    MOBYPOS

    (@mobypos)

    Everything seems to be working normally now – thanks for the quick fix!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Fatal error: Internal Zend error – Missing class information’ is closed to new replies.