WordPress.org

Forums

Fatal error in wp-includes/functions.php on line 1356 (7 posts)

  1. waynster
    Member
    Posted 7 years ago #

    Hi there

    Ok I have been using WordPress for a few years, and today I decided to reinstall a clean copy of wordpress 2.2.

    I started out by completely deleting all the wordpress files from my web host, then dropped all of the database entries so my db is clean (my web host does not allow creation of databases, you just get the one).

    Then I changed the wp-config file as per normal to reflect the database name assigned by my webhost (waynterh), my userid (again waynterh), my password and localhost - all from the standard lookup details from the control panel. I upload all the files to a directory wordpress on my web hosts, go to run the install.php and then bang! I get the following:

    Fatal error: Call to undefined function: did_action() in /home/www/waynterh/wordpress/wp-includes/functions.php on line 1356

    Now line 1356 refers to the unicode setting, but my unicode is all utf8, and was not touched in the file. I've restarted from scratch, recreated the config file again and it still fails. I have confirmed in mySQL and in big letters it says MySQL charset: UTF-8 Unicode (utf8)

    I've tried this three times now from scratch and still it continues to fail - sadly I'm no PHP programmer to really understand why this is going pear shaped - A quick squiz on the internet of the problem (there was nothing I could find in the forum) and the only results come back in German and French - the German I could understand, but the answer not (and that was for a local installation anyway - mine is a run of the mill to the host, and one which has worked before)

    Can anyone maybe give us a clue what the problem might be?

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    The did_action function is contained in wp-includes/plugin.php. Ensure that you have a fresh and correct copy of that file.

  3. waynster
    Member
    Posted 7 years ago #

    The entire install is clean - all downloaded from the new version - due to a restructure and repositioning of the site I decided on a complete blank canvas and none of the files being uploaded are different from those in the downloaded 2.2 package.

    I natuarally checked and indeed the version of the file matches that from the downloaded package, so it isn't that, unless the version packaged is incorrect on the wordpress server (unlikely as I am the only person apparently suffering with this problem)

    Any further ideas?

  4. whooami
    Member
    Posted 7 years ago #

    you didnt rename wp-config-sample.php properly.

    the proof is right here:

    http://www.waynster.com/wordpress/wp-config.php

    http://www.waynster.com/wordpress/wp-config-sample.php

    FOLLOW the instructions.

  5. waynster
    Member
    Posted 7 years ago #

    Forget it...

  6. whooami
    Member
    Posted 7 years ago #

    You're welcome.

  7. nlopes
    Member
    Posted 7 years ago #

    Thanks! Helped me out too!

Topic Closed

This topic has been closed to new replies.

About this Topic