• Resolved rsoareslangara

    (@rsoareslangara)


    Hello CAPTCHA 4WP team,

    thanks for your plugin.

    We are getting the following Fatal error after upgrading PHP from 7.4 to 8.2:

    PHP Fatal error:  Uncaught Error: Using $this when not in object context in /wp-content/plugins/advanced-nocaptcha-recaptcha/includes/class-c4wp-captcha-class.php:565
    Stack trace:
    #0 /wp-includes/class-wp-hook.php(324): C4WP\C4WP_Captcha_Class::ms_form_field_verify()
    #1 /wp-includes/plugin.php(205): WP_Hook->apply_filters()
    #2 /wp-includes/ms-functions.php(586): apply_filters()
    #3 /wp-signup.php(320): wpmu_validate_user_signup()
    #4 /wp-signup.php(666): validate_user_form()
    #5 /wp-signup.php(979): validate_user_signup()
    #6 {main}
      thrown in /wp-content/plugins/advanced-nocaptcha-recaptcha/includes/class-c4wp-captcha-class.php on line 565

    Thanks,

    Rafael

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author robertabela

    (@robert681)

    Hello Rafael,

    Thank you for using our plugin. I am sorry to read about your issue. A few quick questions first:

    1. What version of WordPress and the plugin are you running please?
    2. Are you seeing this error in the debug log and the plugin keeps running or this is a show stopper and the plugin cannot be activated?

    Looking forward to hearing from you.

    Thread Starter rsoareslangara

    (@rsoareslangara)

    Hi Robert,

    many thanks for your quick response.

    The versions are:

    • WordPress version: 6.4.1
    • CAPTCHA 4WP version: 7.3.1

    The login page is working fine, the problem is on the Registration page. I caught the error from the PHP error log in the backend. WordPress didn’t crash for the user, it showed only a “blank page”.

    Thanks,

    Rafael

    Plugin Author robertabela

    (@robert681)

    Thank you for the details and clarification. So just to confirm, this is only happening when a user tries to register, correct?

    Can you please try to enable CAPTCHA on the password reset page and see if the issue persists there as well?

    Thanks.

    Thread Starter rsoareslangara

    (@rsoareslangara)

    It works on the login page, and password reset page as well.

    it does not work on the Registration page.

    We use Google reCAPTCHA v2, BTW.

    Plugin Author robertabela

    (@robert681)

    Thank you for the details. I have just escalated all the information to the developers and we’ll get back to you with an update as soon as possible.

    Thank you for your patience and cooperation.

    Plugin Author robertabela

    (@robert681)

    Hello rsoareslangara,

    Sorry for the delay. We have been unable to reproduce the issue. However, the developers think they know what the issue is so they have prepared a build with the fix.

    Can you please download the build 20231213-advanced-nocaptcha-recaptcha-php-error-patch.zip and advise if this fixes the issue? You can download the patch from our Support download section.

    Looking forward to hearing from you.

    Thread Starter rsoareslangara

    (@rsoareslangara)

    Hi again Robert,

    great, many thanks.

    We are going to test this build on DEV, keep you posted.

    Thanks,

    Rafael

    Thread Starter rsoareslangara

    (@rsoareslangara)

    Hi Robert,

    it seems that this build did the trick!

    The Registration webpage is now working on our DEV environment, without breaking the other pages (login, forgot password, etc).

    We’d prefer to wait until an official plugin version is released, if it does not take so long. Do you have any idea when a new version with this correction will be released?

    Thank you so much.

    Rafael

    Plugin Author robertabela

    (@robert681)

    I am glad to read that Rafael.

    It won’t talk long for the next release. We are wrapping up things and should be able to release an update tomorrow or on Thursday.

    I hope that helps. Please let me know if there is anything else we can do to assist you.

    Plugin Author robertabela

    (@robert681)

    Hello Rafael,

    We have just released update 7.4.0 which include this fix. You can update your installs.

    Please do not forget to spare a minute and rate our plugin and service. These ratings are really helpful.

    Thank you and have a great day.

    Thread Starter rsoareslangara

    (@rsoareslangara)

    Hi Robert,

    thanks for releasing a new version!

    I updated it on PROD however the reCAPTCHA field is not being displayed on the Registration Form, even though we had set it up to be displayed on the plugin settings.

    The field is working normally on the other pages (login, forgot password, etc).

    Do we need to reset something internally? Perhaps a DB update?

    Thank you,

    Rafael

    Plugin Author robertabela

    (@robert681)

    I am sorry to read that Rafael.

    Offhand it is very difficult to tell what could be causing the issue. Would you be able to share the URL of the form in question?

    If you do not want to share this publicly, please send us an email at support@melapress.com with:

    1. The URL of the form
    2. The system information file (from the Help & Contact Us section in the plugin)

    In your email please mention this forum thread so we know which issue it is.

    Looking forward to hearing from you.

    Thread Starter rsoareslangara

    (@rsoareslangara)

    Hi Robert,

    Sorry for the delay, we were in a Winter Break.

    I sent the required information to that Email, Daniel from your team made the first contact.

    I’ll update this thread once we have a resolution.

    Thanks,

    Rafael

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.