Support » Plugin: Admin Search » Fatal error in settings page

  • Resolved cristianuibar

    (@cristianuibar)


    Hello,

    I’m using Bedrock and I’m running on PHP 8.

    This fatal error is shown in the Post Type section on the first checkbox as the label 🙂

    Fatal error: Uncaught TypeError: in_array(): Argument #2 ($haystack) must be of type array, null given in /home/site/webapps/site/web/app/plugins/admin-search/settings.php:527 Stack trace: #0 /home/site/webapps/site/web/app/plugins/admin-search/settings.php(527): in_array() #1 /home/site/webapps/site/web/wp/wp-admin/includes/template.php(1749): admin_search_setting_post_types() #2 /home/site/webapps/site/web/wp/wp-admin/includes/template.php(1707): do_settings_fields() #3 /home/site/webapps/site/web/app/plugins/admin-search/settings.php(292): do_settings_sections() #4 /home/site/webapps/site/web/wp/wp-includes/class-wp-hook.php(307): admin_search_render_plugin_settings_page() #5 /home/site/webapps/site/web/wp/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters() #6 /home/site/webapps/site/web/wp/wp-includes/plugin.php(476): WP_Hook->do_action() #7 /home/site/webapps/site/web/wp/wp-admin/admin.php(259): do_action() #8 /home/site/webapps/site/web/wp/wp-admin/options-general.php(10): require_once('...') #9 {main} thrown in /home/site/webapps/site/web/app/plugins/admin-search/settings.php on line 527

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.