Support » Fixing WordPress » Fatal Error in php, Now I can't login / access my dashboard

  • Resolved kosakra


    I’m fairly new to WordPress and I took over a site for a school publication. I was trying to add a search bar to homepage and ended up making a mistake while adding code to the functions.php file.
    Now I can’t access the website as it is giving me “fatal error: call to undefined function”. I can’t even get back to the dashboard as going to the website’s wp-admin or wp-login is giving me the same error. Is there anyway I can get to my dashboard so I could simply delete the code I added to the functions.php
    Thanks a lot
    PS the site is

Viewing 7 replies - 1 through 7 (of 7 total)
  • If you have a fresh backup of the theme you could replace the functions.php in the theme that is activated using FTP. Please make certain you keep a copy of the functions.php file that you are removing just in case you need to go back to it.

    An alternate method is to rename the theme’s folder by adding “old” to the beginning or ending of the name. That will cause WordPress to revert to the default theme and you will be able to access admin.

    Hope that helps,

    Hello Don,
    I was doing the editing directly from the web so I don’t have an back up of the functions.php
    For the alternative method, how can I access the theme folder so I can rename it? I am really new to this so I’m a little lost on how to do that

    You will need to have FTP access, or access to the File Manager on the hosting service.

    I’m getting the FTP login info now so I can edit the function.php
    Thanks a lot Don

    Please let us know when it’s worked out.


    Hello Don,
    Everything is fixed. All I had to do was log in using Filezilla to get FTP access and I deleted the tiny piece of code I messed up.
    Again thanks a lot Don !


    You are very welcome! I’m glad it all worked out for you.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal Error in php, Now I can't login / access my dashboard’ is closed to new replies.