Support » Plugin: Email Template Designer - WP HTML Mail » fatal error in php 8

  • Resolved nouarah

    (@nouarah)


    Fatal error: Uncaught TypeError: Illegal offset type in isset or empty in /home/nouarahdemo/public_html/wp-admin/includes/plugin.php:574 Stack trace: #0 /home/nouarahdemo/public_html/wp-admin/includes/plugin.php(528): is_plugin_active_for_network() #1 /home/nouarahdemo/public_html/wp-content/plugins/wp-html-mail/includes/class-haet-sender-plugin.php(220): is_plugin_active() #2 /home/nouarahdemo/public_html/wp-content/plugins/wp-html-mail/includes/class-haet-sender-plugin.php(304): Haet_Sender_Plugin::is_plugin_active() #3 /home/nouarahdemo/public_html/wp-content/plugins/wp-html-mail/includes/class-template-designer.php(110): Haet_Sender_Plugin::get_plugins_for_rest() #4 /home/nouarahdemo/public_html/wp-content/plugins/wp-html-mail/includes/class-template-designer.php(48): Haet_TemplateDesigner->get_react_compontent_files() #5 /home/nouarahdemo/public_html/wp-includes/class-wp-hook.php(307): Haet_TemplateDesigner->admin_page_scripts_and_styles() #6 /home/nouarahdemo/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters() #7 /home/nouarahdemo/public_html/wp-includes/plugin.php(476): WP_Hook->do_action() #8 /home/nouarahdemo/public_html/wp-admin/admin-header.php(118): do_action() #9 /home/nouarahdemo/public_html/wp-admin/admin.php(239): require_once('/home/nouarahde...') #10 /home/nouarahdemo/public_html/wp-admin/options-general.php(10): require_once('/home/nouarahde...') #11 {main} thrown in /home/nouarahdemo/public_html/wp-admin/includes/plugin.php on line 574

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Hannes Etzelstorfer

    (@haet)

    Hello @nouarah
    We’ve successfully tested the plugin with PHP 8, can you please share a list of your active plugins, maybe there’s a conflict we need to consider.
    best regards, Hannes

    Thread Starter nouarah

    (@nouarah)

    I deactivated all plugins

    Plugin Support juliangk

    (@juliangk)

    Hello @nouarah,

    does the issue persist?

    Best regards
    Julian

    Thread Starter nouarah

    (@nouarah)

    yes, all my team has face it with the last version Version 3.3.2 , note that we don’t have a problem the version before

    Plugin Support juliangk

    (@juliangk)

    Hello @nouarah,

    We can not recreate this error on our end,
    can you please send us a message to support(at)codemiq.com, concerning this issue.

    Best regards
    Julian

    Plugin Support juliangk

    (@juliangk)

    This error will be fixed with the next update.

    Best regards
    Julian

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.