Support » Plugin: Maintenance Mode » fatal error in latest version + WP 4.9.4

  • Resolved karmak

    (@karmak)


    Hello,

    after having upgraded to everything latest, lj-maintenance-mode crashed :

    Parse error: syntax error, unexpected '[' in /[…]/wp-content/plugins/lj-maintenance-mode/lj-maintenance-mode.php on line 442

    I checked the code, everything seems fine.

    I’m hosted at OVH on mutualized server, I don’t think they have upgraded PHP or updated options.

    I searched for the error on duckduckgo, and many failing websites are coming up with the same error.

    Do you know what could be the origin of that crash ?
    Regards,

    • This topic was modified 1 year, 2 months ago by  .
    • This topic was modified 1 year, 2 months ago by  .
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Lukas Juhas

    (@lukasneptun)

    Hello,

    That appears to be PHP version incompatibility. I believe this requires either PHP 5.4+ or might even need at least version 5.6.

    Usually, you can ask your hosting provider for an upgrade.

    I hope that helps!

    Lukas

    eolet

    (@eolet)

    but why not just use array()? instead of making it incompatible with a LOT of providers? i see no point in using [] and make it incompatible with a lot of servers just to save 5 characters.
    this is the best maintenance mode plugin out there, it shouldn’t fall on such a small issue.

    • This reply was modified 11 months ago by  eolet.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘fatal error in latest version + WP 4.9.4’ is closed to new replies.