Support » Plugin: Yoast SEO » Fatal Error In Last Update

  • Resolved Gruskel

    (@elevas33)


    I have updated Seo By Yoast and I have a fatal error in the internal pages of my site, I have to disconnect the plugin to be able to solve it, this is the message…

    Fatal error: Uncaught PDOException: SQLSTATE[22007]: Invalid datetime format: 1366 Incorrect string value: ‘\xF0\x9F\xA4\x93 %…’ for column manuales_wp1.wp_yoast_indexable.title at row 1 in /home/manuales/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php:464 Stack trace: #0 /home/manuales/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(464): PDOStatement->execute() #1 /home/manuales/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(1983): YoastSEO_Vendor\ORM::_execute(‘INSERT INTO `wp…’, Array, ‘default’) #2 /home/manuales/public_html/wp-content/plugins/wordpress-seo/src/orm/yoast-model.php(662): YoastSEO_Vendor\ORM->save() #3 /home/manuales/public_html/wp-content/plugins/wordpress-seo/src/models/indexable.php(160): Yoast\WP\SEO\ORM\Yoast_Model->save() #4 /home/manuales/public_html/wp-content/plugins/wordpress-seo/src/builders/indexable-builder.php(273): Yoast\WP\SEO\Models\Indexable->save() #5 /home/manual in /home/manuales/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php on line 464
    Ha habido un error crítico en tu web.

    Aprende más sobre la depuración en WordPress.

    One pic—-> https://ibb.co/xCGmRPy

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Joost de Valk

    (@joostdevalk)

    Hey @elevas33, sorry to hear this!

    What’s the charset of your database?

    Thread Starter Gruskel

    (@elevas33)

    Hi! , How do I know what my data base charset is?

    Thread Starter Gruskel

    (@elevas33)

    im noob .

    Same error on my website.

    Uncaught PDOException: SQLSTATE[HY000]: 
    General error: 1366 Incorrect string value: '\xF0\x9F\x92\xA1&#...' for column 'title' at row 1 in 
    /wordpress/current/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php:464 Stack trace: #0 
    /wordpress/current/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(464): PDOStatement->execute() #1 
    /wordpress/current/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(1983): YoastSEO_Vendor\ORM::_execute('INSERT INTO wp...', Array, 'default') #2 
    /wordpress/current/wp-content/plugins/wordpress-seo/src/orm/yoast-model.php(662): YoastSEO_Vendor\ORM->save() #3 
    /wordpress/current/wp-content/plugins/wordpress-seo/src/models/indexable.php(160): Yoast\WP\SEO\ORM\Yoast_Model->save() #4 
    /wordpress/current/wp-content/plugins/wordpress-seo/src/builders/indexable-builder.php(273 in 
    /wordpress/current/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php on line 464
    • This reply was modified 10 months, 1 week ago by Kipperlenny.

    Hello,

    we encounter the same problem :

    Server: Localhost via UNIX socket
    Server type: MariaDB
    Server version: 10.2.31-MariaDB – MariaDB Server
    Server connection collation: utf8mb4_unicode_ci
    Database tables collation: utf8_general_ci

    Error message :

    [28-Apr-2020 14:27:05 UTC] PHP Fatal error: Uncaught PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘blog_id’ in ‘field list’ in /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php:464
    Stack trace:
    #0 /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(464): PDOStatement->execute()
    #1 /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(1983): YoastSEO_Vendor\ORM::_execute(‘INSERT INTO `wp…’, Array, ‘default’)
    #2 /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/src/orm/yoast-model.php(662): YoastSEO_Vendor\ORM->save()
    #3 /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/src/models/indexable.php(160): Yoast\WP\SEO\ORM\Yoast_Model->save()
    #4 /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/src/builders/indexable-builder.php(273): Yoast\WP\SEO\Models\Indexable->save()
    #5 /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/src/builders/indexable-builder in /home/sportqpg/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php on line 464

    Thanks for your help,

    Yup, same problem. Had to disable the Yoast plugin completely to get it working.

    doodleoneal

    (@doodleoneal)

    I also have this issue after updating Yoast Seo to the latest version, but this issue is found on some pages only. Now I have to deactivate the plugin until it will have been fixed.

    • This reply was modified 10 months ago by doodleoneal. Reason: Typo
    Kipperlenny

    (@kipperlenny)

    14.0.1 fixed it on some sites, but not on all sites.

    doodleoneal

    (@doodleoneal)

    14.0.2 that was uploaded three hours ago has solved this issue already.

    Kipperlenny

    (@kipperlenny)

    14.0.2 broke my sites during updating:

    PHP Fatal error occurred: Class ‘Yoast\WP\Lib\Model’ not found in /wp-content/plugins/wordpress-seo/src/models/indexable.php on line 81.

    Thread Starter Gruskel

    (@elevas33)

    problem solved here

    Plugin Support devnihil

    (@devnihil)

    @elevas33 @doodleoneal Thanks for confirming that the most recent update of Yoast SEO resolved your issue. We are going ahead and marking this issue as resolved. If you require any further assistance please create a new issue.

    @kipperlenny @himagarwal Please create a new issue if you are experiencing a similar problem as this helps us in tracking as this can be caused by many different variables (WordPress version, other plugins, etc).

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Fatal Error In Last Update’ is closed to new replies.