Support » Alpha/Beta/RC » Fatal error in Dashboard Widgets (memory exhausted)

  • Kim Parsell


    WP Mom

    I’ve run into an issue this morning where I am getting a fatal error in the Incoming Links dashboard widget in the latest nightly version of 3.0-Alpha:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/xxx/public_html/xxx/wp-includes/class-simplepie.php on line ....

    Update: Getting same fatal error in the WordPress Development Blog widget, Plugins widget, and the Other WordPress News widget is empty.

    I didn’t include the line number as it changes depending on how many of the above-listed dashboard widgets I have activated.

    This error only occurs when I have both the WordPress Beta Tester and the WP-PostRatings plugins activated. If I deactivate either one, the error goes away.

    FYI, my host’s temporary memory limit is set to 64M.

    Not sure anything can be (or should be) done about this, but wanted to post it in case someone else has a similar issue.

Viewing 12 replies - 1 through 12 (of 12 total)
  • This is just what I’m seeing at the moment. I thought something wrong at my php, apache, or even webhosting setting, but seems the problem occured by 3.0-Alpha version. Below is my one.

    WordPress Development Blog Configure

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home2/***/public_html/wp-includes/class-simplepie.php on line 14908

    Other WordPress News



    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home2/***/public_html/wp-includes/class-simplepie.php on line 14908

    Ah, just I got a solution to my post in searching WPForum. With putting the line below into wp-config.php, my dashboard works well.
    Do you think this is safe?

    define(‘WP_MEMORY_LIMIT’, ’64M’);

    I use that code – works well

    Hi Sam!! I ran into this tonight. My server/host is adding that line for me.

    Will this problem be resolved by upgrading to the next version of WP? I am on 2.8.4 currently.

    I emailed you the other day. Did you receive?


    Hmmm – I got something like this some time ago (here) after upgrading to 2.8. That seemed to be an apache config problem and my host sorted it out.

    But now I am getting the problem described here too and it seems to be in the same piece of code, though on a different installation and under 2.9.2 🙁

    Attempts to raise the memory limit to 64M as suggested here and elsewhere do not seem to work and I have referred it to my host. It doesn’t seem to be harming the site itself although traffic is very low at the moment and I’d want to see things fixed before t gets ramped up, so if anybody else has any bright ideas, I’d be glad to hear them.


    OK, I am now sorted ! Kudos to my host for sorting this out. Here’s the story …

    1. I contacted my host support and explained what had happened, referring him to the previous problem that I referred to in my last post (which was something they sorted for me) and to this thread.
    2. Since this definitley seemed to be a memory leak of some kind, I also pointed out that I had installed the TPS! Memory Usage for WordPress plug-in. I have seen several other posts elsewhere in connection with this problem and some claim to have divined the solution by using this. If nothing else, it provides a lot of useful info, especially on the security front. (More details here.)
    3. Today, my host has come back and he feels that the problem was that although the server config had Safe Mode OFF in php.ini, the control panel settings (Plesk) showed it as ON.
    4. He changed this AND made some of the other changes suggested by the TPC! plug-in and all is now well. Hurrah !

    I have seen the "define('WP_MEMORY_LIMIT', '64M');" solution suggested above by samboll in other places for people having similar problems. It seems to work for some and not others – maybe this is why: perhaps it’s more to do with safe mode than anything else. But I’m no expert – but what I DO know is that a good tech guy at your host is really what you need when it gets this esoteric.

    Hope that this helps anybody else suffering from the same type of problem.

    All the best !

    This is a problem in 3.0…

    But where the easy fix of changing the memory limit in the wp-setings.php normally is it is now not there…

    in 3.0 where do we make the fix?

    unable to change WP_MEMORY_LIMIT in wordpress 3.0 beta wp-settings.php

    blynnerobson, if you’re using 3.0 beta, it may all get worked out by the time the code is finalised. But if you are using 3.0, you probably know a lot more about WordPress than I do 😉

    However, the feeling from my host was that the WP_MEMORY_LIMIT “fix” may be something of a Band-Aid. There may be a bug underneath all this, but experimenting with Safe mode may be worth trying if you haven’t done so already.

    So I’d really recommend anybody still having this problem to look in to that, or at least, get their host to do so.


    Hello all,
    i have been trying to amend the memory limit from 64mb to 128mb by adding the line
    define(‘WP_MEMORY_LIMIT’, ’64M’);
    to configure.php or others on php.ini, htacess and also the cache.php
    but seem like nothing change.

    and under the GD PRESS TOOl i can see that my php memory is still 32MB and used memory 29.3mb

    what can i do?my wordpress version is 3.0.1

    Hi lillier,

    I had the same problem as there queqlues months, I managed to solve this problem by using the php.ini file.

    check that your php.ini is as follows:

    [Large code excerpt removed by moderator. Per forum rules, please use the pastebin for all large code excerpts. It works better anyway.]

    ssallc, I love you! After many hours troubleshooting and searching it was the define(‘WP_MEMORY_LIMIT’, ’64M’); that fixed it. I was struggling with nested foreach. It would always fail with more than one foreach. Now it works perfectly.

    As well, for the longest time some feeds would just not respond, but pasting the link directly in the browser would get you there. This is the problem I was having there as well.

    FYI: this problem went away when I deactivated WP-PostRatings.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Fatal error in Dashboard Widgets (memory exhausted)’ is closed to new replies.