Fatal error in file.php (5 posts)

  1. michlm
    Posted 6 years ago #


    got a problem there, nothing exasperating, but it's still annoying me. I recently changed my domain without any problem (WP 2.7 then) - except for one: Trying to access the FTP-server via admin panel (e.g. to install or update a plugin) didn't work and the error given was:

    Warning: extract() [function.extract]: First argument should be an array in [...] /wp-admin/includes/file.php on line 691

    Lines 690 and 691 in file.php told me following:

    if ( !empty($credentials) )
            extract($credentials, EXTR_OVERWRITE);

    Hoping that the problem would resolve itself I updated to 2.7.1. The old error message fortunately disappeared but now I find a new one:

    Fatal error: Cannot use assign-op operators with overloaded objects nor string offsets in [...]/wp-admin/includes/file.php on line 688

    The respective code on 687 and 688 is:

    if ( !empty($stored_credentials['port']) ) //save port as part of hostname to simplify above code.
                $stored_credentials['hostname'] .= ':' . $stored_credentials['port'];

    The frontend of my site works good btw. Can't find anything that helps me out on the net. Someone here with a possible explanation?

    Thanks a lot,

  2. Kampfflummi
    Posted 6 years ago #

    I have to bump this as I have the exact same error. Same file, same line, same problem.

  3. kingkong954
    Posted 6 years ago #

    Another bump -- same error.

    Is this a permissions problem, or is there a missing library perhaps?

  4. Shane G
    Posted 6 years ago #

    Hi. I'm getting this error on my scripts:

    Fatal error: Cannot use assign-op operators with overloaded objects nor string offsets in c:\inetpub\wwwroot\usap\reports\Daily_Report_Student.php on line 40

    After doing some searching, I concluded the errors are caused by using .=, +=, etc on an array.

    $Report["Where"] .= " Battalion = 2 ";

    or something similar. The error is eliminated if you replace the line with

    $Report["Where"] = $Report["Where"] . " Battalion = 2 ";

    The odd thing is code from one server to another and it's just now showing up. The error is running 4.2.0, IIS, and Win2K. The other machine is Win2K with IIS also.

    So did you migrated your blog..? or check for the correct error..at mentioned and replace it with the original values


    Shane G.

  5. michlm
    Posted 5 years ago #

    Someone on the German board solved the problem: http://bit.ly/12j96F

Topic Closed

This topic has been closed to new replies.

About this Topic