Support » Plugin: Jilt for Easy Digital Downloads » Fatal error in 1.4.0

  • Resolved Jonathan Christopher

    (@jchristopher)



    Hi there! Just wanted to report this error after updating to 1.4.0:

    [31-Jul-2018 16:39:29 UTC] PHP Fatal error: Uncaught Error: Cannot use object of type stdClass as array in /wp-content/plugins/jilt-for-edd/includes/api/class-edd-jilt-api.php:135

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Jilt

    (@jilt)

    Hey @jchristopher, thanks for the report! We’ve deployed version 1.4.1 to resolve this issue. Could you please manually update via FTP?

    I’m really sorry you ran into this error, I know it’s a pain to manually update. We dropped the ball here in not handling an expired OAuth token properly in our upgrade (this issue affected shops that have a token locally that has expired remotely). We’re already at work on adjusting the way upgrade routines are run in future versions to avoid repeating an error like this. I apologize for the inconvenience with this update + manual upgrade to v1.4.1 again. Mind giving it a go and letting me know if this issue is now resolved for you?

    Cheers,
    Beka

    Good to go! 👍

    Plugin Contributor Jilt

    (@jilt)

    🍻 thanks for letting me know!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.