WordPress.org

Support

Support » How-To and Troubleshooting » Fatal Error – Image Uploading

Fatal Error – Image Uploading

  • I’ve got an image that is 5.4MB’s which is no biggie, never had issues uploading such that I am aware. Our upload is set to 64MB’s. Problem is that this image is extremely long (excessively in all honesty) in dimensions. I “can” slice it up but I don’t want too. I want to fix whatever issue instead.

    I get the famous error at the end of the upload/crunching:

    Fatal error: Out of memory (allocated 57933824) (tried to allocate 4000 bytes) in /home/mysite/wp-includes/media.php on line 258

    I have checked my phpinfo file to see what that’s allowed by host and it’s 64.

    I’ve done the htaccess thing, the config file thing, php.ini, checked my settings, you name it. Everything I can find via a search I’ve checked.

    The one odd thing to me is that my Woo Themes support keeps sending me to my host who I am positive won’t help. They never do. But when I use my Woo Canvas theme it says “Tried to allocate 4,000 bytes”. But if I try the two default wp themes (twenty ten or whatever) then it states “Tried to allocate 1,000 bytes”. So it seems like these numbers are being controlled by something in the theme and not my host doesn’t it? Any ideas what controls that “Tried to allocate” number?

    It also appears to upload the image completely regardless of the fatal error if I click on the gallery but the dimensions say 0px by 0px. If I add it into the post it looks correct in the wysiwyg though?

    Ideas? Since Woo Support isn’t helpful and god knows my host won’t help so this was the only place I could think to turn after searching and trying all those options. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal Error – Image Uploading’ is closed to new replies.