WordPress.org

Support

Support » Plugins and Hacks » Genealogy » [Resolved] Fatal error Genealogy Plugin

[Resolved] Fatal error Genealogy Plugin

  • Fatal error: Call to undefined function get_the_post_thumbnail() in /home1/root/public_html/website/wp-content/plugins/genealogy/genealogy.php on line 994

    I keep getting that error when i try to add a family member

    I cannot add extra fields for additional information

    Family member not diplaying when i have added a family member.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The plugin requires at least WordPress 3.0; the function get_the_post_thumbnail() was added in WordPress 2.9, so I think you need to upgrade.

    I am using wordpress 3.1.2. Ive tried the plugin on 3 different sites

    I keep getting a thumbnail error in the backend

    When i click ‘view family member’ I get a 404 error that the page does not exist.

    When i try to add an extra field for additional information, nothing happends, it just highlight the one thats already there.

    Ah, well then, have you tried using the default twentyten theme? It likely will work there.

    Newer themes with support for get_the_post_thumbnail() should work. I forgot to think about older themes that may not support it.

    Regarding adding an extra field, try using Firefox or Chrome browsers and let me know if that works. It may be an issue with Internet Explorer browsers.

    Some issue here – I’d really like to use the plugin but apparently it isn’t supported by my theme (based on your diagnosis above).

    For others in the same boat as me, is there a quick way to modify the theme to make it compatible?

    Thanks

    Zack Katz

    @katzwebdesign

    I think adding the following to your theme’s functions.php file would work:

    if(!function_exists('get_the_post_thumbnail')) {
    	function get_the_post_thumbnail() {
    		return false;
    	}
    }
    Zack Katz

    @katzwebdesign

    I have just added a check in the plugin code to fix this issue in version 1.2.1. Please let me know if this resolves that issue.

    Family member info now shows up correctly with the update – so far so good! Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Fatal error Genealogy Plugin’ is closed to new replies.
Skip to toolbar