• JerryPignolet

    (@jerrypignolet)


    Restrict content caused a fatal error on this site. The host support found this error message below. The site is using PHP 7.4, plugin version 3.1.9. Current status is that the plugin is deactivated and the content unprotected. We need a fix.

    “NOTICE: PHP message: PHP Fatal error: Uncaught Error: Class ‘RCP_Telemetry’ not found in /www/wp-content/plugins/restrict-content/restrictcontent.php:130”

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 37 total)
  • solari1

    (@solari1)

    I’m seeing the same issue with 3.1.9. php version 8.1.

    Error Details
    
    An error of type E_ERROR was caused in line 130 of the file /var/www/home/wp-content/plugins/restrict-content/restrictcontent.php. Error message: Uncaught Error: Class "RCP_Telemetry" not found in /var/www/home/wp-content/plugins/restrict-content/restrictcontent.php:130
    Stack trace: 0 /var/www/home/wp-includes/class-wp-hook.php(308): RC_Requirements_Check->plugins_loaded() 1 /var/www/home/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters() 2 /var/www/home/wp-includes/plugin.php(517): WP_Hook->do_action() 3 /var/www/home/wp-settings.php(480): do_action() 4 /var/www/home/wp-config.php(92): require_once('…') 5 /var/www/home/wp-load.php(50): require_once('…') 6 /var/www/home/wp-admin/admin.php(34): require_once('…') 7 {main} thrown
    r3db0

    (@r3db0)

    yes with the same bug like @jerrypignolet

    wcat007

    (@wcat007)

    Same error here PHP 7.4.30, plugin v 3.1.9. Just upgraded the plugin from 3.1.8 and it broke the site. Had to disable it.

    databell96

    (@databell96)

    Same problem here. A2 Hosting. PHP 7.4.

    databell96

    (@databell96)

    These are the errors I got:

    Fatal error: Uncaught Error: Class 'RCP_Telemetry' not found in /home/ifwtwaor/yoursite.com/wp-content/plugins/restrict-content/restrictcontent.php:130 Stack trace: #0 /home/ifwtwaor/yoursite.com/wp-includes/class-wp-hook.php(308): RC_Requirements_Check->plugins_loaded('') #1 /home/ifwtwaor/yoursite.com/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array) #2 /home/ifwtwaor/yoursite.com/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #3 /home/ifwtwaor/yoursite.com/wp-settings.php(480): do_action('plugins_loaded') #4 /home/ifwtwaor/yoursite.com/wp-config.php(96): require_once('/home/ifwtwaor/...') #5 /home/ifwtwaor/yoursite.com/wp-load.php(50): require_once('/home/ifwtwaor/...') #6 /home/ifwtwaor/yoursite.com/wp-admin/admin.php(34): require_once('/home/ifwtwaor/...') #7 /home/ifwtwaor/yoursite.com/wp-admin/index.php(10): require_once('/home/ifwtwaor/...') #8 {main} thrown in /home/ifwtwaor/yoursite.com/wp-content/plugins/restrict-content/restrictcontent.php on line 130

    Notice: Function is_embed was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /home/ifwtwaor/yoursite.com/wp-includes/functions.php on line 5835

    Notice: Function is_search was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /home/ifwtwaor/yoursite.com/wp-includes/functions.php on line 5835

    Plugin Author James Welbes

    (@highprrrr)

    i think I’ve seen this before, can you try deleting and reinstalling the plugin?

    arswebdesign

    (@arswebdesign)

    Same issue after upgrading. Not real hep on the suggestion to delete and reinstall as it would probably require updating all the pages with restrictions again. Decided not to deal with it. Pulled 3.1.8 from yesterday’s backup and replaced the folder for the site. That appears to have worked, but still checking.

    Plugin Author James Welbes

    (@highprrrr)

    deleting and reinstalling would not require updating your pages with restrictions again

    Plugin Author James Welbes

    (@highprrrr)

    @solari1 your issue is a completely different error from the OP. Restrict Content does not yet support PHP 8.1. you should consider asking your host to downgrade to 8.0

    Plugin Contributor Israel Barragan

    (@reedyseth)

    We are currently working to replicate the error since we are not able to see it. There might be something in your system/server that we can’t match.

    I will suggest safely deleting the plugin. You don’t have to set the option “Remove Data on Uninstall” enabled. This means that your information will remain in your system. Even though this process does not delete your information please run a website backup.

    After deleting the plugin install it again as you regularly do in the “Add new” section of the plugins.

    I think that you system was not able to do the files cleaning in the update.

    We will keep trying to replicate the issue in our end.

    Plugin Author James Welbes

    (@highprrrr)

    could someone experiencing this issue open the file mentioned and let us know what line 130 says? It sounds like for some reason your file wasn’t replaced with the new file during the update

    asaynisch

    (@asaynisch)

    this function is the one affected:

        public function plugins_loaded() {
            // Initialize Telemetry.
            $container = new Container();
            Config::set_hook_prefix( 'rcp' );
            Config::set_stellar_slug( 'restrict-content' );
            if ( defined('TELEMETRY_SERVER') ) {
                Config::set_server_url( TELEMETRY_SERVER );
            }
            else {
                Config::set_server_url( 'https://telemetry.stellarwp.com/api/v1' );
            }
            Config::set_container( $container );
            Telemetry::instance()->init( __FILE__ );
    
            $rcp_telemetry = new RCP_Telemetry();
            $rcp_telemetry->init();
        }

    Line 130:

    $rcp_telemetry = new RCP_Telemetry();

    Uncaught Error: Class ‘RCP_Telemetry’ not found

    Edit:
    Reinstalling doesn’t solve the problem. I got it working again by commenting out lines 130 and 131.

    • This reply was modified 1 year ago by asaynisch.
    zeddee

    (@zeddee)

    Same problem found here. Any news yet on when the issue will be resolved?

    daemonanime

    (@daemonanime)

    me sumo error y pagina caida ojala reparen el error

    oddunicorn

    (@oddunicorn)

    Same error here too.

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘Fatal error from Restrict Content plugin’ is closed to new replies.