WordPress.org

Support

Support » Installation » [Resolved] Fatal Error during Upgrade to 2.5

[Resolved] Fatal Error during Upgrade to 2.5

  • Hi All,
    I have a problem during upgrade the WP 2.3.3 to 2.5,
    After all file exclude the content, and we try to go to dashboard, and the system ask me to upgrade database, and after that we found the message like this:
    Fatal error: Call to undefined function: populate_roles_250() in /home/——-/public_html/optikonline/wp-admin/includes/upgrade.php on line 727

    so hurry up, <b>please help me</b>

Viewing 5 replies - 1 through 5 (of 5 total)
  • The function populate_roles_250 is in wp-admin/includes/schema.php so makes me think that you at least don’t have a good version of that file.

    I’d consider deleting the WordPress files and reuploading as per Steps 7 and 8 in Upgrading_WordPress_Extended.

    I tried to install folder ” admin/include” and now the message above not appear.
    But Now after login or if i open my blog http://optikonline.info, we found this message:

    Fatal error: Call to undefined function: hash_hmac() in /home/ic—–/public_html/optikonline/wp-includes/pluggable.php on line 518

    Now, i am uploading again all file in folder wp-includes
    we wait the result
    thanks

    At last.

    Upgrade is finished and success
    Thanks to Michael
    C U

    Hello,

    I’ve encountered the same problem however I forgot to de-active all my plugins before installing the updates and have no back up. Any thoughts or help would be great. My stupid fault.
    Thanks

    PT

    Nevermind.
    Thanks for everything!
    Wordpress is GREAT!
    PT

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Fatal Error during Upgrade to 2.5’ is closed to new replies.
Skip to toolbar