Support » Installing WordPress » Fatal Error doesnt make sense

  • Chelsea

    (@chelsea)


    OK.. I recently attempted to upgrade from WordPress 1.2 (or so I do believe) to 1.5 and am having a lot of issues. This is one of them:

    I unzipped the .zip Strayhorn file and extracted all. I proceeded to upload, and then it brought up several of those:


    <code> Warning: main(/home/unchaine/public_html/wp-includes/template-functions.php): failed to open stream: No such file or directory in /home/unchaine/public_html/wp-settings.php on line 41

    Warning: main(/home/unchaine/public_html/wp-includes/template-functions.php): failed to open stream: No such file or directory in /home/unchaine/public_html/wp-settings.php on line 41

    Fatal error: main(): Failed opening required '/home/unchaine/public_html/wp-includes/template-functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/unchaine/public_html/wp-settings.php on line 41

    Now, I looked in the extracted files and they do not include a template-functions.php….. I’m kind of lost here. Help, anyone?

Viewing 15 replies - 1 through 15 (of 26 total)
  • oriecat

    (@oriecat)

    Maybe your wp-settings.php file didn’t get replaced with the new one?

    Chelsea

    (@chelsea)

    I uploaded the new wp-settings.php.. no change for the better. 🙁

    Chelsea

    (@chelsea)

    Oh, now I’m getting a whole new error here.

    Warning: Invalid argument supplied for foreach() in /home/unchaine/public_html/wp-settings.php on line 113

    oriecat

    (@oriecat)

    Did you delete the old one first or just overwrite it? I just looked at my wp-settings.php file and it doesn’t call for template-functions anywhere, so if yours still is then there is something wrong with it.

    oriecat

    (@oriecat)

    Did you remember to deactivate all of your plugins before upgrading?

    Chelsea

    (@chelsea)

    I didn’t deactivate anything, I simply deleted everything except for my modified files and uploaded the new WP files.

    My wp-settings file still calls for template-functions for some reason, though.. I just deleted it and uploaded another one.. still calls for it, and it’s the one from Strayhorn.. odd…

    vkaryl

    (@vkaryl)

    What did you do about your database? Some info will be stored there, I think I remember reading somewhere. And the database for 1.2.* doesn’t have the same number of tables that 1.5’s db does….

    You were following the procedure for upgrading in the README, right? Just checking to be sure….

    Chelsea

    (@chelsea)

    The error changed. ( Big whoop. )

    Warning: main(/home/unchaine/public_html/wp-settings.php): failed to open stream: No such file or directory in /home/unchaine/public_html/wp-config.php on line 31

    Fatal error: main(): Failed opening required ‘/home/unchaine/public_html/wp-settings.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/unchaine/public_html/wp-config.php on line 31

    Chelsea

    (@chelsea)

    and yes, I did backup my database.

    vkaryl

    (@vkaryl)

    Ummmm – hmm. Would seem to me that your wp installation should be in something like “public_html/wordpress/” – your first error listed there seems to be looking for the wp-config.php file in your root folder.

    Chelsea

    (@chelsea)

    When I upgraded, I moved all of the files to the root folder instead of in a sub-directory. Is that why I’m having so much problems?

    vkaryl

    (@vkaryl)

    Well, I don’t know for sure, but I would (if this were me), delete everything and start over, putting wp in its own folder….

    Chelsea

    (@chelsea)

    Well, I want the main page to be WordPress powered. Previously I had it in a sub-directory, and linked to the index.php through a i-frame. I now want the whole page to be WordPress – I don’t know of any other way of doing this without having WP installed in the main directory.. Sorry.. I’m a little new.

    vkaryl

    (@vkaryl)

    You should be able to do that with the Pages function in 1.5, without having it resident in the root folder. I don’t know that root folder residency is the problem with your install though. It was simply a thought, since your error message was looking for the file in a place I wouldn’t have expected it to be living.

    Chelsea

    (@chelsea)

    I want my blog to be on the front page, not a WP page. . . . Can I have the index.php file in the main directory and still have the WP install in a sub-directory? Is this possible?

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Fatal Error doesnt make sense’ is closed to new replies.