• Resolved maxplateau

    (@maxplateau)


    Hello,
    With the latest update of your plugin, I had a fatal error :

    Uncaught Error: Call to undefined function Beehive\GuzzleHttp\choose_handler() in /wp-content/plugins/beehive-analytics/dependencies/vendor/guzzlehttp/guzzle/src/HandlerStack.php:39

    I’ve found the plugin which caused conflict (LatePoint) and I have reset config of Beehive, reinstalled the plugin and there was no fatal error anymore.

    But now, when Beehive ask me to connect with Google, I can’t connect anymore. The fatal error is now only triggering when i want to connect with Google.

    So i’ve fallback to the version 3.3.11 and I can connect with Google with this version.

    Please fix this error so I can update your plugin. For now, i’ve disabled automatic updates of your plugin.

    Thanks,

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @maxplateau

    I hope you’re well today!

    It’s not quite clear to me so let me ask: the error that you are now getting (with newest release of Beehive) when trying to connect to Google – is this the same error? The one about “guzzle” that you earlier identified as a conflict with other plugin?

    Or is it a different error – if it’s different, what the error says specifically?

    Kind regards,
    Adam

    Thread Starter maxplateau

    (@maxplateau)

    Hello,
    I’m using the latest version of your plugin 3.3.13.
    I want to connect with Google but after I pasted the access code and click on the button Authorize, I get the message : “We couldn’t connect your Google account. Please try reconnecting with the “Connect” button below”.
    I think this message appears because I’ve a fatal error:
    Fatal error: Uncaught Error: Call to undefined function Beehive\GuzzleHttp\choose_handler() in /wp-content/plugins/beehive-analytics/dependencies/vendor/guzzlehttp/guzzle/src/HandlerStack.php:39
    To be able to connect with Google, I need to disable the plugin Latepoint and his extensions. So I disabled the Latepoint plugin and enabled again after a succesful connection with my Google account.
    I don’t have this fatal error with the version 3.3.11
    Regards,

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @maxplateau

    Thank you for the update.

    We found an issue with the GuzzleHttp which is one dependence of the Google Analytics package.

    Our developers already fixed it and the release is coming as soon as possible, kindly keep the 3.3.11 for now and eyes on our upcoming updates.

    Best Regards
    Patrick Freitas

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @maxplateau

    I hope you are doing well.

    We would like to let you know that we released the fixed version, could you please update the plugin and check if the issue is gone?

    Best Regards
    Patrick Freitas

    Thread Starter maxplateau

    (@maxplateau)

    Hello,
    The issue is gone, the plugin is working well.
    Thanks !

    Regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal Error Connect with Google’ is closed to new replies.