WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Fatal Error Code – Events Manager Update

[Resolved] Fatal Error Code – Events Manager Update

  • Hey Frank…got a new question. (BTW…the a.STRING(4 solution you previously offered fixed the error log issue! – thanks)

    I just updated the Events Manager plugin by Marcus Sykes to v 5.5.3. I’m getting this error code at the bottom of the front-end user form for adding events.

    Fatal error: Uncaught exception ‘JSMin_UnterminatedStringException’ with message ‘JSMin: Unterminated String at byte 504663: “===a.STRING(4,5).toUpperCase()?r():!1):!1’ in /home/collecto/public_html/wp-content/plugins/autoptimize/classes/external/php/minify-2.1.7-jsmin.php:203 Stack trace: #0 /home/collecto/public_html/wp-content/plugins/autoptimize/classes/external/php/minify-2.1.7-jsmin.php(145): JSMin->action(1) #1 /home/collecto/public_html/wp-content/plugins/autoptimize/classes/external/php/minify-2.1.7-jsmin.php(84): JSMin->min() #2 /home/collecto/public_html/wp-content/plugins/autoptimize/classes/autoptimizeScripts.php(175): JSMin::minify(‘?try{jQuery.noC…’) #3 /home/collecto/public_html/wp-content/plugins/autoptimize/autoptimize.php(249): autoptimizeScripts->minify() #4 [internal function]: autoptimize_end_buffering(‘<!DOCTYPE html>…’, 9) #5 /home/collecto/public_html/wp-content/plugins/wp-external-links/includes/class-wp-external-links.php(125): ob_end_flush() #6 [internal function]: WP_External_Links->callba in /home/collecto/public_html/wp-content/plugins/autoptimize/classes/external/php/minify-2.1.7-jsmin.php on line 203

    If I turn off the Javascript function in Autoptimize the message disappears. Any thoughts?

    Regards,
    William

    https://wordpress.org/plugins/autoptimize/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Frank Goossens

    @futtta

    This probably is due to an error in the javascript of Event Manager, the Events Manager devs might be able to assist in fixing this?

    Ok..thanks for verifying this.

    Regards,
    Will

    Plugin Author Frank Goossens

    @futtta

    NP. I would, for now, just exclude Event Manager’s JavaScript.

    I’ve been trying to figure out what to put in the exclude for events manager…but nothing I have tried worked…mmm…

    Plugin Author Frank Goossens

    @futtta

    “events-manager”?

    I am experiencing this issue as well, but I don’t have that plugin. I also am experiencing a high amount of latency, I am also unable to minify and compress js in the footer or anywhere when the Look for scripts only in <head> is enabled. Force JavaScript in <head> when unchecked also causes issues. Ideas?

    Look for scripts only in head is what appears to be causing the problem, when it isn’t checked, it causes the error to occur.

    Plugin Author Frank Goossens

    @futtta

    Hi Brashell;
    Some questions/ feedback;

    • are you getting the exact same error that BigDogSF is seeing?
    • It might not be optimal form a performance point of view, but a lot of jquery-based themes need “force js in head” and “look only in head. You can, alternatively, disable “look only in head” but you’ll have to search for the JS that is causing problems and exclude that, which might take some trial and error.
    • latency typically occurs if you don’t have a page cache plugin (e.g. wp super cache).

    hope this helps,
    frank

    Plugin Author Frank Goossens

    @futtta

    Ah, missed your 2nd remark. This means that one of the javascripts outside of head has a bug in it which causes the JS minifier to throw an error.

    Just out of curiosity, are you declaring $content only here? Because it might make sense why it only works when just head is checked.

    if($options['justhead'] == true)
    		{
    			$content = explode('</head>',$this->content,2);
    			$this->content = $content[0].'</head>';
    			$this->restofcontent = $content[1];
    		}

    Or am I missing it?

    Plugin Author Frank Goossens

    @futtta

    you’re missing it; $content is available before (and is used in the explode), but it is changed (the head is chopped off 😉 ) if justhead==true.

    plupload.full.min.js Is the file causing the problem I determined, by adding it to the whitelist it all works, but at the same time, it adds a ton of latency.

    Question, is there a way to split it up to multiple files?

    Plugin Author Frank Goossens

    @futtta

    1. where do you see the latency brashell; loading of the base page (HTML), the loading of the aggregated JS (CSS), or loading the excluded files? and when talking latency, do you mean “time to first byte” or the actual download?
    2. splitting the aggregated js (css) file up is not possible i’m afraid.
    3. plupload.full.min.js is a great catch, thanks for that!! given it’s popularity I might add it to the default JS exclusion list.

    Time to first byte, and all files including base load, one of the pages has over 1MB from a single file then because the system won’t split it up not sure what to do.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Fatal Error Code – Events Manager Update’ is closed to new replies.