Fatal error clicking Customize theme (6 posts)

  1. msct
    Posted 3 years ago #


    Working with a fresh install of 3.4.1, I've installed a new theme – Imbalance 2 – via FTP, and now get an error when clicking 'Live Preview' or 'Customize' links.

    These links worked with the default 'Twenty Eleven' before the new theme install, but now the same error crops up whichever theme I install. Here's the error:

    Fatal error: Call to a member function theme() on a non-object in /home/user/wordpress/wp-admin/customize.php on line 60

    This is driving me mad as I'm now unable to customize themes and can find nothing relating to this problem in other posts.

    Any help would be greatly appreciated.

  2. bjrhodes
    Posted 3 years ago #

    Hi, For anyone else with this problem, we found this to be a fairly subtle bug with virtualmins default cgi implementations and wordpress. Tracking this down was a pain, but the fix was simple enough. Switch from cgi based su_exec to Fcgi and wordpress is fine.

  3. bratsling
    Posted 3 years ago #

    Hello.. I'm having the same error. My site is hosted on Dreamhost and my PHP mode is 5.2x FastCGi and it's still not working. Any other thoughts?

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    As per the Forum Welcome, please post your own topic. Your problem - despite any similarity in symptoms - is likely to be completely different.

  5. bjrhodes
    Posted 3 years ago #

    Following a bit of a bump yesterday, I realised my previous post may be a bit cryptic. We found the fix that worked for us thanks largely to this thread:

    For similar issues where switching execution mode isn't possible or doesn't work, you may want to try setting cgi.fix_pathinfo to "0" in your php.ini file.

    Your mileage may vary.

  6. bratsling
    Posted 3 years ago #

    I ended up doing a complete re-install and it seems to be working now. Thanks everyone.

Topic Closed

This topic has been closed to new replies.

About this Topic