Support » Plugin: Gutenberg Template Library & Redux Framework » Parse error class-redux-import-export.php (fix)

  • Resolved mrtvy.kenny

    (@mrtvykenny)


    There is unnecessary comma in the code that causes Fatal Error on probably older PHP versions…

    The Error:

    Parse error: syntax error, unexpected ')' in /www/doc/www.XXXX.com/www/wp-content/plugins/redux-framework/redux-core/inc/extensions/import_export/import_export/class-redux-import-export.php on line 63

    The problem (and fix):
    locate the file /wp-content/plugins/redux-framework/redux-core/inc/extensions/import_export/import_export/class-redux-import-export.php and find line 63.
    delete the last comma before the right bracket

    fixed line is:
    $secret = wp_create_nonce( 'redux_io_' . $this->parent->args['opt_name'] );

    • This topic was modified 2 months, 1 week ago by mrtvy.kenny.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Kev

    (@kprovance)

    Which version of PHP are you using?

    I encountered this same error and had to disable the plugin to get my site to load. How do I see my PHP version from the WP admin dashboard?

    OK, I just found it. My site is on GoDaddy and is using PHP version 7.2.34. Should I wait for a fix to the plugin? I’d rather not go to the trouble of editing script files to fix this.

    Plugin Author Kev

    (@kprovance)

    Version 4.2.14 has been deployed to resolve this issue.

    Awesome, thanks for the quick response!

    @kprovance
    Since 03-Sep-2021 I got the same / similar error in my website.
    It´s Hosted with Hostgator.
    Any idea how can I fix it.
    Thanks in advance!

    • This reply was modified 1 month, 2 weeks ago by joseja1969.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.