Support » Plugin: Jetpack by WordPress.com » Fatal error – class.jetpack-ixr-client.php

  • Resolved zimbo000

    (@zimbo000)


    I have just updated the plugin on 2 different websites to 7.5.3

    Both resulted in Fatal errors.

    Here are the messages from each site:

    Fatal error: Uncaught Error: Class ‘Automattic\Jetpack\Connection\Client’ not found in /www/sites/680/774/dev.jacksgallery.co.uk/web/wp-content/plugins/jetpack/class.jetpack-ixr-client.php:38 Stack trace: #0 /www/sites/680/774/dev.jacksgallery.co.uk/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-actions.php(191): Jetpack_IXR_Client->query(‘jetpack.syncAct…’, Array) #1 /www/sites/680/774/dev.jacksgallery.co.uk/web/wp-includes/class-wp-hook.php(286): Jetpack_Sync_Actions::send_data(Array, ‘deflate-json-ar…’, 1564657993.29, ‘sync’, 0.010468006134, 0.0149071216583) #2 /www/sites/680/774/dev.jacksgallery.co.uk/web/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #3 /www/sites/680/774/dev.jacksgallery.co.uk/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(244): apply_filters(‘jetpack_sync_se…’, Array, ‘deflate-json-ar…’, 1564657993.29, ‘sync’, 0.010468006134, 0.0149071216583) #4 /www/sites/680/774/dev.jacksgallery.co.uk/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-send in /www/sites/680/774/dev.jacksgallery.co.uk/web/wp-content/plugins/jetpack/class.jetpack-ixr-client.php on line 38

    Fatal error: Uncaught Error: Class ‘Automattic\Jetpack\Connection\Client’ not found in /www2/122/dev.americanroadtrips.net/web/wp-content/plugins/jetpack/class.jetpack-ixr-client.php:38 Stack trace: #0 /www2/122/dev.americanroadtrips.net/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-actions.php(191): Jetpack_IXR_Client->query(‘jetpack.syncAct…’, Array) #1 /www2/122/dev.americanroadtrips.net/web/wp-includes/class-wp-hook.php(286): Jetpack_Sync_Actions::send_data(Array, ‘deflate-json-ar…’, 1564659344.34, ‘sync’, 0.00375604629517, 0.00838208198547) #2 /www2/122/dev.americanroadtrips.net/web/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #3 /www2/122/dev.americanroadtrips.net/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(244): apply_filters(‘jetpack_sync_se…’, Array, ‘deflate-json-ar…’, 1564659344.34, ‘sync’, 0.00375604629517, 0.00838208198547) #4 /www2/122/dev.americanroadtrips.net/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(124): Jetpack_Sync_Send in /www2/122/dev.americanroadtrips.net/web/wp-content/plugins/jetpack/class.jetpack-ixr-client.php on line 38

    I have seen similar errors reported in other posts but no apparent resolution.

    I have other sites to update – is this a problem and/or is there a fix?

    WordPress Site Health also now reports:
    A scheduled event has failed – Performance
    The scheduled event, jetpack_sync_cron, failed to run. Your site still works, but this may indicate that scheduling posts or automated updates may not work as intended.

    Is this another problem?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support lizkarkoski

    (@lizkarkoski)

    Hi –

    Jetpack is not actively installed on either site (jacksgallery.co.uk and
    americanroadtrips.net). Please connect Jetpack and let me know once that is done. Then I can take a closer look at what’s going on.

    Both sites were – and still are – connected to Jetpack and WordPress.com.

    See images.

    https://imgur.com/jQdeCfr

    https://imgur.com/LrydmZF

    And both sites report…

    Debugging Centre
    Testing your site’s compatibility with Jetpack…
    Your Jetpack setup looks a-okay!

    Please note the fatal errors were reported on the ‘dev.’ versions of the website, which are test/development servers. There are live www versions of each site but I have not updated Jetpack on those yet after receiving the fatal errors on the dev sites.

    Plugin Contributor Tim Moore

    (@tmoorewp)

    What version of PHP are you using?

    Both sites are running 7.2 although the hosting company has just made 7.3 available.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    At least according to tests from our end, Jetpack is working properly at both dev.jacksgallery.co.uk and dev.americanroadtrips.net now.

    I see you’re running Jetpack 7.5.3 on WordPress 5.2.2 under PHP 7.2.19 on both as well.

    So, that shouldn’t be a problem.

    I’m also not finding any recent bug reports of this exact error.

    The first thing I’d suspect is maybe a corrupted or broken installation.

    Please try deleting Jetpack specifically from the Plugins section of your blog’s Dashboard: https://jetpack.com/support/reconnecting-reinstalling-jetpack/#reinstalling-jetpack

    This will clear out Jetpack’s settings, and it should work properly after a reinstall.

    I deleted then re-installed Jetpack on both sites. Everything appears to be working.

    So I then updated Jetpack on the live site, https://www.americanroadtrips.net, from 7.4.1 to 7.5.3

    Result:

    Fatal error: Uncaught Error: Class ‘Automattic\Jetpack\Connection\Client’ not found in /www1/da7/www.americanroadtrips.net/web/wp-content/plugins/jetpack/class.jetpack-ixr-client.php:38 Stack trace: #0 /www1/da7/www.americanroadtrips.net/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-actions.php(191): Jetpack_IXR_Client->query(‘jetpack.syncAct…’, Array) #1 /www1/da7/www.americanroadtrips.net/web/wp-includes/class-wp-hook.php(286): Jetpack_Sync_Actions::send_data(Array, ‘deflate-json-ar…’, 1564832770.81, ‘sync’, 0.00633692741394, 0.0116579532623) #2 /www1/da7/www.americanroadtrips.net/web/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #3 /www1/da7/www.americanroadtrips.net/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(244): apply_filters(‘jetpack_sync_se…’, Array, ‘deflate-json-ar…’, 1564832770.81, ‘sync’, 0.00633692741394, 0.0116579532623) #4 /www1/da7/www.americanroadtrips.net/web/wp-content/plugins/jetpack/sync/class.jetpack-sync-sender.php(124): Jetpack_Sync_Sender in /www1/da7/www.americanroadtrips.net/web/wp-content/plugins/jetpack/class.jetpack-ixr-client.php on line 38

    This is another completely separate website so there’s clearly a problem with Jetpack somewhere.

    The site appears to be working OK. Debug says Your Jetpack setup looks a-okay! Site Health reports that “Jetpack’s async local testing suite passed all tests!”

    Can you investigate further on the site or should I just delete the plugin and re-install as with the other sites?

    Plugin Support KokkieH

    (@kokkieh)

    I don’t see anything wrong from our side either, so please go ahead and do a clean re-install of the plugin.

    Did you also update the other two sites from 7.4.1 to 7.5.3? I wonder if a specific difference between those two versions isn’t causing a file to become corrupted during the update. That seems plausible here, as we haven’t had other reports of this exact error that we can find.

    Or is there any other commonality between the sites? Maybe a specific plugin you use on all three?

    I just updated the live Jack’s Gallery site from 7.4.1 to 7.5.3 and did not get the fatal error. I also did another 2 sites and did not get the error either.

    The common plugins between the 3 sites are Autoptimize, WP-Optimize and UpdraftPlus.

    I guess we can close this if you’re not seeing this error elsewhere and I’m not getting any issues after doing a re-install on the sites it did occur on?

    Plugin Support KokkieH

    (@kokkieh)

    Yeah, it’s unlikely that any of those plugins would have caused an issue.

    As we’re not able to replicate this, and it doesn’t appear to be a recurring issue, let’s call this resolved, but please do let us know if it happens again on a next update.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.