Support » Plugin: Easy Watermark » Fatal error: Class 'finfo' not found

  • Resolved Ian


    Hi there, installed Easy Watermark plugin fine.

    Changed settings and uploaded image to use for watermarking.

    Tried to watermark existing images, but getting this error:

    Fatal error: Class ‘finfo’ not found in /home/XXXXXXXX/domains/ on line 915

    What does this mean?

    Thanks for your time, cheers, Ian

Viewing 3 replies - 1 through 3 (of 3 total)
  • I tested and can manually use the “Add watermark” per image, but have several hundred so not really an option.

    Hopefully you can help figure out why the bulk option doesn’t work, thanks.

    Plugin Author szaleq


    Hi Ian,

    This error is caused by the fact that you has no ‘fileinfo’ extension enabled on your server. This extension is used by EasyWatermark class to get an information about image mime type, etc., but it is only needed if the class has only image path given. Normally wordpress has all needed information in the database so the mime type should also be taken from there and no finfo function should be used… I’ll try to figure out what’s happening there, but if you’re able to enable fileinfo extension for your php, it will work for sure.


    I just contacted Hostgator and they upgraded me to Php version 5.3. Now it works. Thanks! I’ll send a donation your way, because your plugin was a huge help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal error: Class 'finfo' not found’ is closed to new replies.