Support » Themes and Templates » Fatal error: Class ‘CachedFileReader’ not found in …\wp-l10n.php on line 67

  • I’ve just begun a new site with WP 2.0.1 and was switching between several themes to help decide which to use, when this error came up, and now I cannot access anything in the blog… neither the blog itself nor the admin part.

    I didn’t make any changes in the process of switching from “Rampart” to “WP BinaryBlue” but when I tried to switch to the latter I got the error message.

    Any suggestions?

    TIA

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have this same error on a fresh install, and the only admin action i’ve taken is swapping to a new theme. I’ve reproduced three times, switching to any new theme.

    any help ? I can provide a URL/access for reproduction if any coders are available.

    surely we can’t be the only 2 ?

    Hey, I’m new but I got a similar error yesterday that then reproduced in every theme that I tried to swap to. It was the Relaxation theme for me. Anyway, the way that it got fixed was by going into the config.php for WordPress and adding English as the language, like so:

    define (‘WPLANG’, ‘en_US’);

    That cleared up my error. Maybe it will help with yours.

    I had the identical problem — after switching between Kubric and K2, I tried Binary-Blue K2ed. I edited the config.php file as suggested and it seems to have fixed it.

    I have added define (‘WPLANG’, ‘en_US’); to wp-config.php, but I still get this error in Wordpres 2.02:

    Fatal error: Class ‘CachedFileReader’ not found in /home/.canicula/jamesgreig/tonguengroove.co.uk/wp-includes/wp-l10n.php on line 67

    Have I missed something stupid?

    Ah ok – the full solution is described at http://wordpress.org/support/topic/72270

    “Then you have to open the “lang” folder that came with wp-slimstats and rename the file from wp-slimstat-en_US.mo to just en_US.mo. That gets slimstats working.”

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error: Class ‘CachedFileReader’ not found in …\wp-l10n.php on line 67’ is closed to new replies.