Support » Fixing WordPress » Fatal Error & can’t log in to fix it

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hey Indu,

    it looks like it works now?

    In the case that a plugin (or a theme) makes a problem and you can’t log in tto your admin-dashboard to fix that, you can deactivate the plugin via the ftp.

    FTP is the area on your server, where your files are. To access the ftp you will need a Programm (FTP-Client) for example Filezilla. Than you need the login for your FTP, which you get from your Hosts.

    Once you are connected with your FTP, search for the folder “wp-content”. There is a folder for plugins and for themes. Now you can deactivate a single plugin by renaming (just add a number for example) the folder of this specific plugin (for example mojo-marketplace-wp-plugin) or you can also deactivate every plugin by renaming the folder “plugins”.

    Hi Maja,

    Seems like I have precisely the same issue. About a week in, this exact error appeared just now. I’ve followed the instructions above and it worked, I can now access the wp-admin.

    I was wondering why did this happen and if there’s anything else that I must do now, to ensure it doesn’t happen again?

    Thanks

    Hey,

    the only thing you can do is, to make sure your WordPress (including Themes and Plugins) are up to date, using good written plugins and not too many plugins.

    But there is no guarantee, that this not happen again, becasue there is always the chance, that someting breaks. But now you know how to solve this problem 🙂

    Hi all,
    I have had a fatal error message when i tried to install a Give plugin. I now can’t get into the back end of my website at all. I have downloaded FileZilla to try and get into the back end that way but it isn’t connecting, it keeps repeating:

    Error, could not connect to server
    Trying to reconnect in 5 seconds
    Connecting to server https://southwarkgiving.org:14147…
    Error, could not connect to server
    Trying to reconnect in 5 seconds
    Connecting to server https://southwarkgiving.org:14147…
    Error, could not connect to server

    I’m using the default port number: 14147 is that correct? If not how do a get a different port number? Is the host name my full website address? and is my password my website password? If this is all correct how else can i connect to FileZilla?

    Thanks!

    Hi Maya,
    It seems as if you have good experience on the use of Word press and web sites. I have the warning below when I try to open my web page for 4 days. I couldn’t solve it by myself. I need your advice for the solution steps.

    Fatal error: Can’t use function return value in write context in /home1/gator000/public_html/wp-content/themes/vantage/inc/sliders.php on line 112

    thank you

    sertac

    thanks @travel_girl, you saved my day!

    I installed a plugin and now my entire site is giving me this:

    Fatal error: Call to a member function add_rewrite_tag() on a non-object in /home/10/96/3029610/web/wp-includes/rewrite.php on line 172

    Please help.

    Thanks in advance.

    Hal

    You just saved me, as well, @travel_girl. Thank you.

    Hi @travel_girl, what if we do not have an FTP account yet (which is my case right now 🙁

    Due to the plugin Fatal Error cannot even login to admin page.

    Without a FTP account, there is only one other way to rename a folder and that would be a SSH connection. But it is unfortunately very unlikely that you would have a SSH connection when you have not yet received the FTP credentials (as they are often the same).

    Thanks! I could find the ftp credentials and resolved the issue by renaming the plugin folder.

    I wish at least the admin page would be accessible in any case. thanks for your help. Cheers.

    hiroshibata

    (@hiroshibata)

    Thank you @travel_girl. I had a similar problem when deactivating and re-activating plugins. It happened with Jetpack, which I trust the most among many plugins.

    Now, I re-installed Jetpack, made sure there are newly made “jetpack” folder and the renamed one, “jetpack1” folder. But if I try to activate the newly-installed one, the sane problem happens again.
    Is there any way to retrieve it?
    Please kindly let me know if I should ask this to Jetpack.

    Thank you,

    weardrama01

    (@weardrama01)

    Hello,

    OMG, I updated a plug-in and I can no longer see my webpage or login. I’m very new to wordpress and not sure how to fix this. Freaking out ;/

    Getting this error:
    Fatal error: Cannot redeclare class acf_field_flexible_content in /home/weardram/public_html/weardrama.com/wp-content/themes/dramaboutique4/inc/acf-flexible-content/flexible-content.php on line 537

    Website: weardrama.com

    Dear friends,

    I have already posted a message on wordpress on the recent problem I encounter. as of today I cannot have access to my website, which returns me the fatal error below:

    Fatal error: Uncaught Error: Using $this when not in object context in /home/agenceli/public_html/wp-content/themes/itheme2/themify/themify-utils.php:1711 Stack trace: #0 /home/agenceli/public_html/wp-includes/class-wp-hook.php(286): themify_setup_menu_icons(”) #1 /home/agenceli/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /home/agenceli/public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /home/agenceli/public_html/wp-settings.php(450): do_action(‘init’) #4 /home/agenceli/public_html/wp-config.php(99): require_once(‘/home/agenceli/…’) #5 /home/agenceli/public_html/wp-load.php(37): require_once(‘/home/agenceli/…’) #6 /home/agenceli/public_html/wp-admin/admin.php(31): require_once(‘/home/agenceli/…’) #7 /home/agenceli/public_html/wp-admin/update-core.php(10): require_once(‘/home/agenceli/…’) #8 {main} thrown in /home/agenceli/public_html/wp-content/themes/itheme2/themify/themify-utils.php on line 1711

    any idea on how to fix this one? I am so very much not skilled with IT and can bearly update my website, but it’s something I need for my professional activities. Could you please help out?

    thank you so much in advance for your time,

    Cristina

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fatal Error & can’t log in to fix it’ is closed to new replies.