Support » Plugin: Elementor Page Builder » Fatal Error, cant create posts

  • Resolved Stefan Pejcic

    (@stefanpejcic)


    I cant create a new post/page/category.. anything except media upload really when Elementor is active.

    When I deactivate it all works normally.
    I’ve switched to the default wp theme and deactivated all other plugins but still the same..

    I get this error on wp-admin when trying to add new with Elementor active:

    The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

    and the following in the error log:

    [12-Oct-2019 12:21:37 UTC] PHP Fatal error: Uncaught Error: Call to a member function get_meta() on bool in /home/wporb/public_html/wp-content/plugins/elementor/modules/usage/module.php:390
    Stack trace:
    #0 /home/wporb/public_html/wp-content/plugins/elementor/modules/usage/module.php(188): Elementor\Modules\Usage\Module->remove_from_global(false)
    #1 /home/wporb/public_html/wp-includes/class-wp-hook.php(286): Elementor\Modules\Usage\Module->on_before_delete_post(‘0’)
    #2 /home/wporb/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
    #3 /home/wporb/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    #4 /home/wporb/public_html/wp-includes/post.php(2814): do_action(‘before_delete_p…’, ‘0’)
    #5 /home/wporb/public_html/wp-includes/post.php(6708): wp_delete_post(‘0’, true)
    #6 /home/wporb/public_html/wp-includes/class-wp-hook.php(286): wp_delete_auto_drafts()
    #7 /home/wporb/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)
    #8 /home/wporb/public_html/wp-includes/plugin.php(531): WP_H in /home/wporb/public_html/wp-content/plugins/elementor/modules/usage/module.php on line 390

    Any help would be highly appreciated, I use the same theme along with Elementor on 10+ sites and I’m afraid this might happen across the network.

    Thanks in advance.

    • This topic was modified 7 months, 3 weeks ago by Stefan Pejcic.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Sounds like maybe some serialized data got corrupt. The way WordPress stores some types of data is through serialized arrays where each string provides a matching index and number of characters that match said length of the string. If one were to go into the database, find some text inside a serialized array and change it a bit without recalculating and adjusting the character length to properly match the new modified string, this will likely result in a Fatal error. This is just a hunch based on the function get_meta() returning false (bool).

    If this sounds like something that might have happened you’ll need to fix your database either using some sort of tool to scan and fix serialized data throughout or make manual corrections.

    If this doesn’t sound like anything you’ve done then the best approach is to start high level by eliminating things one by one until we flush out the problem.

    First thing I would check is to ensure that the Elementor plugin does not have any missing files. Try uploading a fresh copy. You can also check the system information Elementor provides where errors may be listed that provide some clues.

    After that I’d make a duplicate of my site (if my site is in production) and deactivate all other plugins and see if the problem resolves, if it does, re-active each plugin until you find the conflict.

    If it doesn’t, try changing your theme and apply the same logic as above.

    If it still doesn’t work consider maybe something in your WordPress installation or server setup may be causing this.

    Do you see any errors in the browser console when navigating wp-admin or the front end while Elementor is active?

    If you have access to your wp-config.php enable debugging and see if you see any non-fatal errors in the debug log that could be a clue. (if there are errors, the log is found in the /wp-content/ folder)

    You may have additional logs that could be viewed on your server or through your host tools.

    Lastly, if you have Pro, you could also open a ticket with Pro support.

Viewing 1 replies (of 1 total)
  • The topic ‘Fatal Error, cant create posts’ is closed to new replies.