WordPress.org

Forums

Wordfence Security
Fatal error: Cannot use object of type WP_Error as array (2 posts)

  1. a_hemant
    Member
    Posted 2 years ago #

    Updated to the latest version today.

    While scanning observed repeating Fatal errors as follows:

    Fatal error: Cannot use object of type WP_Error as array in /home/mydata/public_html/myblog/wp-content/plugins/wordfence/lib/wfScanEngine.php on line 911

    https://wordpress.org/plugins/wordfence/

  2. Wordfence
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks, I've fixed this issue and it'll go out with the next release.

    If you'd like to fix it yourself in the current release, you can delete the following two lines in lib/wfScanEngine.php:


    wordfence::status(4, 'info', "Proxy scan start headers: " . var_export($result['headers'], true));
    wordfence::status(4, 'info', "Proxy scan start response: " . var_export($result['response'], true));

    Anyone else seeing this issue? Leaving this open for a few hours until I hear back.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Wordfence Security
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic