Support » Fixing WordPress » Fatal error: Cannot redeclare preview_theme() (previously declared in

  • Resolved rinoux

    (@rinoux)


    *sorry for my bad English*

    hi,

    today when I upgrade my blog something went wrong and I had this message “Briefly unavailable for scheduled maintenance. Check back in a minute.” so I deleted the .maintenance as some people say. but now I cant acces to my blog anymore, this is the message i got “Fatal error: Cannot redeclare preview_theme() (previously declared in /var/alternc/html/l/lovielhcasse/wp-includes/theme.php:650) in /var/alternc/html/l/lovielhcasse/wp-includes/deprecated.php on line 3506” my blog is http://www.lovielhcasse.lautre.net/

    someone can help me ? thank you very much.

    Rinoux

Viewing 15 replies - 1 through 15 (of 24 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

    hi James, thank you for your answer !

    Ok, I renamed the themes but i got the same error message…

    http://www.hostingpics.net/viewer.php?id=639686Capturedu20150819003711.png

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    What theme were you using before?

    What was the result of resetting your plugins?

    I think i used sigma…

    “What was the result of resetting your plugins?” I cant find phpMyAdmin…

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    “What was the result of resetting your plugins?” I cant find phpMyAdmin…

    Then try the FTP method also listed at the link.

    I think i used sigma…

    Ok, you renamed that, so it’s likely a plugin then, not the theme.

    I did the following commands

    Via FTP or your host’s file manager, navigate to the wp-contents folder (directory)
    Via FTP or your host’s file manager, rename the folder “plugins” to “plugins.hold”
    Login to your WordPress administration plugins page (/wp-admin/plugins.php) – this will disable any plugin that is “missing”.
    Via FTP or your host’s file manager, rename “plugins.hold” back to “plugins”

    but i cant login when i go to /wp-admin/plugins.php , i only got the same error message…

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Fun, it’s neither of those. Time for a manual reinstall.

    Try downloading WordPress again and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    ok, thank you for your kind help, i’ll reinstall it tomorrow.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    You’re welcome!

    Hello. I have the same problem.
    I update wordpress to the last versiĆ³n in mode automatic. I have Plesk in Godaddy.

    The error is:

    Fatal error: Cannot redeclare preview_theme() (previously declared in G:\PleskVhosts\***********.es\httpdocs\wordpress\wp-includes\theme.php:650) in G:\PleskVhosts\***********.es\httpdocs\wordpress\wp-includes\deprecated.php on line 3506

    Please help me.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    If the above didn’t work for you, please open your own thread: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    My site is also crashed after the update. Same Plesk hosting in GoDaddy. Is the server causing the trouble?

    Replacing with the latest wordpress files helped. it is the automatic update setting caused the issue. Now my site is back. Thanks.

    Hi dprabu76, Can you explain the steps taken to do the same?.
    Thanks.

    I just followed what James Huff had mentioned above.

    Download the latest WordPress v4.3 from the wordpress.org, unzip it. Then login to GoDaddy. Go to the File manager > httpdocs folder. Create a folder called “Old”. Move all the existing wordpress files to “old” folder except the wp-config.php file and the /wp-content/ directory. Now upload all the manually downloaded wordpress files to httpdocs folder. Check if your website is back to normal. Then you can safely remove Old folder.

    For me, it may be the Automatic update setting that caused the issue. Auto Update broke and didn’t complete.

    Hope this helps.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Fatal error: Cannot redeclare preview_theme() (previously declared in’ is closed to new replies.