Support » How-To and Troubleshooting » Fatal error: Cannot redeclare disable_all_widgets!!!????

Fatal error: Cannot redeclare disable_all_widgets!!!????

  • Hi,
    I have the easel theme on wordpress and just installed the bbpress plugin. Was desperately searching for a way to get rid of the sidebars/ widgets on the forum pages.

    Have now messed up the theme.php bit (down the right hand side of wordpress panel when you go into editor).

    I am getting the error:
    Fatal error: Cannot redeclare disable_all_widgets() (previously declared in /home/___.com/wp-content/themes/easel/functions.php:417) in /home/____.com/wp-content/themes/easel/functions.php on line 447

    I have no idea how to fix this. Can anyone PLEASE help?

    Thanks in advance.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Try deactivating all plugins and revert to Twenty Eleven theme and see if the problem persists. If the problems are related any plugins, activating the plugins one by one can help you locate the problem. After you resolve the problem, you can put back your themes and plugins.

    Oh no! I just tried clicking on my plugins menu and i get the error again! I cannot edit my site at all!!

    Your site URL?


    Try to replace the files out of the themes and upload them back into the directories..

    Or take an ftp backup of the themes files, then reinstall the theme.

    Then start tweaking again, one teak at a time…:)

    hope that helps

    Your site has security warnings as seen in this report. That perhaps causes the problems, need not necessarily be a case of hacking or infection.

    It is possible that either your site is disabled by your host or some contents are missing.

    Try these:
    1. Contact your host for support. Perhaps that may solve the problem.
    2. If you have a backup of your site, reinstall WordPress and restore from your backup. Do it in such a way that if it is an infection, no security holes are left.

    Easel doesn’t have a “disable_all_widgets” function inside of it.

    Hi, the site is only 3 days old so there is no malware etc on it lol.

    Frumph I’m not sure what easel does or doesn’t have, but if you type in my site address, that’s the error message it gives.

    Thanks Krishna, I contacted dreamhost but they said to access the site via ftp, and I am not sure how to do that. I am a complete and utter noob to all of this. I have been editing/ tweaking my site simply from bits and peices I have read on the web. The error arose after i had done a number of things to try and remove the sidebars from my forum page after installing bbpress.

    I am not in a position to pay for help, so am trying to do the best i can to muddle through this by myself.

    Peter – is there a way i could get the site back up and running as it was before i managed to break it? i had a number of widgets already set up and pages that were looking good. If there’s a way i can save all that instead of starting again from scratch I’d be really interested to hear?

    OK, I have managed to get in via ftp. I am now looking at a list of my site’s files. Do I just delete the themes folder?

    Delete wp-content/themes/easel and reinstall it from the wordpress repo; should return everything back to normal before you started modifying it.

    Also, there’s options in the theme to disable sidebars for specific pages; for things like forums.

    Crisis over. I managed to get in via ftp, delete the easel theme as Frumph suggested, now I have re-installed it and my site is back up, all pages intact woopeeeee 🙂

    Now, before I break it again, does anyone know how the hell i can get rid of these darn sidebars/ widgets from the page i have my forum on?

    I want the forum full width, like a normal forum, without my twitter, and all the other gumph i’m going to put down the rest of the other pages.

    I don’t have an appropriate membership level to view that 😉 also btw you can when you edit a page disable commenting by in hte upper right hand corner there’s a tab, click it and checkmark [x] discussion, then in under the editor box there’s a checkmark for allow commenting, uncheck that.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Fatal error: Cannot redeclare disable_all_widgets!!!????’ is closed to new replies.