WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Fatal error: Cannot redeclare class

[Resolved] Fatal error: Cannot redeclare class

  • Hello.

    I am working on a new WP site, have a few plugins going, but not a lot of content or customization, other than css styles on my theme.

    Anyway, I installed Contact Form 7 (version 3.9), activated it, fine.
    Installed Really Simple CAPTCHA 1.8 (use these two on several other sites we develop, and love them), but the plugin doesn’t activate, it shows this error when I try to activate it:

    Fatal error: Cannot redeclare class ReallySimpleCaptcha in /home/content/p3nexnas06_data02/24/2145124/html/wp-content/plugins/really-simple-captcha/really-simple-captcha.php on line 30

    Site is hosted in GoDaddy, unfortunately, via their cumbersome VPS WordPress hosting control panel.

    I tried deleting and reinstalling, same thing happened. Any ideas?

    Thanks,
    Maria M.

    https://wordpress.org/plugins/really-simple-captcha/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Takayuki Miyoshi

    @takayukister

    Try switching to the default theme and deactivating all other plugins.

    Ok, it looks like the conflict is with the theme. But now I can’t access the WP admin at all.

    I deactivated all plugins, and activated the default theme. Then activated RSC and it worked fine. Then I reactivated all other plugins, one by one. And all was fine. At the end, I activated my theme, and I am getting a similar “cannot redeclare class” php error and can’t see the admin. 🙁

    Fatal error: require_once(): Cannot redeclare class reallysimplecaptcha in /home/content/p3nexnas06_data02/24/2145124/html/wp-content/themes/blanco/code/init.php on line 27

    How do I revert the theme, perhaps via FTP I can do this?

    Thanks!!

    Ok, I found a solution to get my WP admin back up.

    Any ideas how to resolve the conflict with my theme?

    Plugin Author Takayuki Miyoshi

    @takayukister

    I don’t think it is a “conflict”. It’s rather an intentional abuse by the theme. I suggest giving up the themeforest theme and switching to more reliable one from wordpress.org.

    Wow, I see. Ok, thanks a bunch! You rock.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Fatal error: Cannot redeclare class’ is closed to new replies.