Support » Fixing WordPress » Fatal error: Cannot redeclare admin_register_head

  • Good morning,

    Could someone tell me how to fix this plugin error? or at least get my image uploader to work again.


    I installed a plugin (easily navigate) last week and tried to activate it this morning, but I get an error message and now I can’t upload any pics to the site. It seems to be conflicting with the WP-Cufon plugin.

    Fatal error: Cannot redeclare admin_register_head() (previously declared in /var/www/vhosts/ in/var/www/vhosts/ on line 166

    Also, we’ve made some changes to the site’s content this weekend. So I’d like to be able to fix the error without losing all the work we’ve done so far.

    Site is

    I’ve deleted the “easily navigate” plugin but I am still unable to add pictures to the site. I guess deleting that plugin is fine with me as long as I can upload images again.

    Well, actually uploading is not the issue, the image gets uploaded but there is no preview of the image so I am assuming it didn’t get uploaded properly. I’ve tested it and when I try to use one of the newly uploaded images I get a blank thumbnail.

    I’ve also changed the permissions on the content-upload folder to 777 and it still doesn’t work.

    Is there an ez way to fix it or troubleshoot the issue for the image uploader?

    Thank you,


Viewing 1 replies (of 1 total)
  • Also, would upgrading to WP 3.4.1 solve this issue or break it further?

    I would also appreciate an easy method to backup the site.

    Thank you,


Viewing 1 replies (of 1 total)
  • The topic ‘Fatal error: Cannot redeclare admin_register_head’ is closed to new replies.