Support » Installing WordPress » fatal error cannot redeclare…

  • Resolved tiffiney

    (@tiffiney)


    Tried the automatic upgrade. Now I get this error when accessing any part of my site or admin.

    Fatal error: Cannot redeclare get_link() (previously declared in /home/mome/public_html/blog/wp-includes/bookmark.php:93) in /home/mome/public_html/blog/wp-includes/deprecated.php on line 2053

    Can someone help? Easy fix I hope. Ugh! I hate update time!
    Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • btw, this was after attempting the automatic upgrade.

    Moderator James Huff

    (@macmanx)

    Try resetting your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename everything except the /twentyten/ directory. This will force the Twenty Ten theme to activate and hopefully rule-out a theme-specific issue.

    i renamed the plugins folder to plugins-old. that didn’t work. i can’t access the admin area, everything gives me that same msg. so i am working in the ftp. i didn’t see anything in the themes folder that said twentyten? the only folders are default, prophoto2, prophoto3, and themes, and an index.php document

    Moderator James Huff

    (@macmanx)

    In that case, try renaming everything except /default/ to force the Default theme to activate.

    nope didn’t work

    attempting the manual upgrade now. since the automatic was a failure. maybe it will fix the issue

    now i can access the admin area. but the blog link has a blank screen.

    Moderator James Huff

    (@macmanx)

    Try disabling all plugins and switch to the default theme.

    Hello!
    I m currently having exactly the same problem as tiffiney, I upgraded automatically my wordpress and got that message:
    Fatal error: Cannot redeclare get_link() (previously declared in /homez.311/thebomba/www/wp-includes/bookmark.php:93) in /homez.311/thebomba/www/wp-includes/deprecated.php on line 2053

    I was using “Lysa” theme and I was wandering if maybe it was compatible or not with the new wordpress. I dont have access to /wp-admin so I can’t change anything, I tried to change the names on my FTP but it didnt work either.
    I give you also the line of code that looks wrong (the number 2052 and 2053 of deprecated.php)

    Note that I tried what you said but I didn’t try the manual update as I really have no idea of how to do it. I m kind of a noob
    Here is the line of code:
    2052 : return get_bookmark($bookmark_id, $output, $filter );
    2053 : }

    Thank you !

    Moderator James Huff

    (@macmanx)

    Try manually resetting your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the Default theme (WordPress 1.5 – 2.9.2) or the Twenty Ten theme (WordPress 3.0 and higher) to activate and hopefully rule-out a theme-specific issue.

    If you need further assistance, please start your own topic.

    Hello James,
    I created a topic there: http://wordpress.org/support/topic/bug-after-upgarde?replies=1#post-1813125 as you adviced me after trying what you said. thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘fatal error cannot redeclare…’ is closed to new replies.