Support » Plugin: DobsonDev Shortcodes » Fatal error: Cannot declare class Parsedown, because the name is already in use

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter mrswed

    (@mrswed)

    with other plugins it get fatal error

    same trouble https://github.com/Harrix/Harrix-MarkdownFile/issues/3

    Plugin Author DobsonDev

    (@dobsondev)

    Hello –

    I’m working on a fix now and will update you when I’m done. I’ve installed the other Harrix Markdown plugin and am working to get both working at the same time.

    Thanks!

    • This reply was modified 2 years, 1 month ago by DobsonDev.
    Plugin Author DobsonDev

    (@dobsondev)

    Hello –

    I’ve come up with a fix. I tried to check if the class already existed but that caused issues in that if you loaded the plugins out of order then you would get the same error.

    What I ended up doing was renaming my Parsedown class from it’s default name to a plugin specific name. This does mean that potentially two instances of Parsedown could be loaded but the effect on performance is basically nothing.

    Everything is working now so update your plugin with version 2.1.12 and everything should work.

    Thanks for letting me know about this issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal error: Cannot declare class Parsedown, because the name is already in use’ is closed to new replies.