Support » Plugin: Responder » Fatal error: Cannot declare class OAuthSignatureMethod_HMAC_SHA1

  • Adam Pery

    (@adam1920)


    I got fatal error:
    Fatal error: Cannot declare class OAuthSignatureMethod_HMAC_SHA1, because the name is already in use in /home/gilihask/public_html/wp-content/plugins/responder/responder_SDK/OAuth.php on line 127

    Next files have the same class declaration (class OAuthSignatureMethod_HMAC_SHA1)

    lib/responder_SDK/OAuth.php
    responder_SDK/OAuth.php

Viewing 1 replies (of 1 total)
  • I found the source of the problem.
    My theme (kakia) uses the same oauth.net PHP library for authentication to twitter.

    I’m suggesting to you guys to use php namespace to prevent class name conflicts.

    Regards

Viewing 1 replies (of 1 total)
  • The topic ‘Fatal error: Cannot declare class OAuthSignatureMethod_HMAC_SHA1’ is closed to new replies.