Support » Plugin: Google Analytics Dashboard Plugin for WordPress by MonsterInsights » Fatal error: Cannot call overloaded function for non-object in /home/host/publi

Viewing 15 replies - 1 through 15 (of 18 total)
  • I received the same error. My blog was completely down. I logged into my hosting account and deleted analytics for wordpress from my files. I then was able to login to wordpress and my blog was back up. I then uploaded the previous version of analytics and everything seems to be working ok now. Hopefully it stays that way.

    I received the same error. My blog is completely down!!

    public_html/wp-content/plugins/google-analytics-for-wordpress/frontend/abstract-class-tracking.php on line 286

    This is happing in 9 site that we support that is runing this plugin.

    Same problem here. My site’s been going down frequently over the past 24 hours after updating this module. The error message is:

    Fatal error: Cannot call overloaded function for non-object in public_html/wp-content/plugins/google-analytics-for-wordpress/frontend/abstract-class-tracking.php on line 286

    Here’s a hack that gets my site running again until this is fixed:

    Edit abstract-class-tracking.php and add “return false;” to the beginning of this function:

    public function do_tracking() {
    			// hack to "neuter" crashing code
    			return false;
    
    			global $current_user;
    			...

    update the PHP version from native 5.4 to 5.5. It will solve your problem.

    remember to uncheck APC and don’t install more than 3 wordpress when godaddy 1GB shared hosting ram.

    This is happing in 9 site that we support that is runing this plugin.
    All site 5.5 PHP with there own cPanel and 1 copy of WordPress running.

    @moshiurmix – Thanks! I restored the original file and switched to PHP 5.5 and things are working fine again.

    For sites who cannot easily update to PHP 5.5, this issue is not “resolved”. Will this be fixed for real in the next update? Disabling the plugin until then.

    I am also now experiencing this and I will disable as well until resolved.

    I also have been experiencing this since the update on my clients site on GoDaddy. Upgrading to PHP 5.5 has so far resolved the issue. If I experience it again I will post.

    Changing PHP to version 5.5 on GoDaddy seems to have resolved it.

    You must not be on a shared server with GoDaddy – as those of us who are cannot change the PHP version 😕

    @fionavar, if you are on a Cpanel hosting account (shared or reseller) on GoDaddy, you can log in to Cpanel, go to the Software/Services section, click on Select PHP Version, and change to 5.5.

    Upgrading to 5.5 resolved for me too. Thanks to @moshiurmix for the fix.

    @fionavar – You can also call support and request they change the PHP version to 5.5. I am on a shared host environment with CPanel.

    I have had no issues in the last 24hours regarding this error, but now Visual Composer has broken. 🙁

    I think the PHP version change broke Visual Composer from WP Bakery. Onto another support thread!

    Thanks Fregan – I am on there WP platform and was told they cannot do that.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Fatal error: Cannot call overloaded function for non-object in /home/host/publi’ is closed to new replies.