Support » Fixing WordPress » Fatal Error: Cannot call overloaded function for non-object

  • Hello Everyone,

    I have moved my WordPress site across onto a cPanel hosting plan on GoDaddy.

    Now however when I click around the site the page either loads up oddly or I get this error message:

    Fatal error: Cannot call overloaded function for non-object in /home/internetgenie/public_html/internet-genie.co.uk/wp-includes/class-wp.php on line 529

    This seems to happen whether it is on the front end or the back end of the site.

    Does anyone know what I would need to do to fix this.

    Many thanks in advance!

Viewing 15 replies - 16 through 30 (of 37 total)
  • Try re-activating the plugins one by one until you find the problematic plugin(s).

    Hi @internetgenie,

    I visit your site and I got the error when I clicked Home.

    Have you tried calling Godaddy?

    How many active plugins do you have?

    Thanks,

    My site is https://globaledgeconsultantsllc.com/. Let me know if you encounter the issue. It seems working now. I just uninstalled & delete some plugins. Something to do with godaddy hosting though because when I checked the status yesterday it says that we are on limited status for 24hrs.

    By the way, it is not something to do with Theme. I am on Catch Katmandu Theme, yet I encountered the same problem.

    Thanks,

    zaldeg

    Apologies I have just come back now,

    @esmi – I have gone through the plug-ins now and activated them one-by-one, I did encounter an issue when I installed the Testimonials plug-in so I removed that but I had to leave it overnight and when I came back like @zaldeg stated the issue suddenly appeared again.

    @zaldeg – thank you for letting me know you spotted the issue on my site I have had a click around on the link above and I have not encountered the issue on yours. I also contacted GoDaddy and they did confirm to me that there is CPU limitations but the person I spoke to said Managed WordPress would not work and told me we will need to upgrade to a server for a higher cost (it seems when you speak to them you get different answers dependent on who it is). With regards to the plug-ins I did have more active but I have gone through and tried to reduce the plug-ins to as low as I can so there are currently 20 plug-ins on their active. At the moment I do not think I can replace any of these with code snippets as the site is one which I built for the company I work for as an apprentice and writing codes is not something at the moment I am comfortable with.

    it seems when you speak to them you get different answers dependent on who it is

    I’m afraid we see that a lot with GoDaddy. Very often, you have to really push to try and get decent answers to your questions. Have you considered moving to another host? I know I would.

    /home/internetgenie/public_html/internet-genie.co.uk/wp-includes/class-wp.php on line 529

    I have just contacted GoDaddy now and I did get another suggestion from them. This time they followed the link mentioned in the error message to that file and that line.

    They told me it was a caching issue with WordPress and they tried it on three different computers and they apparently could not recreate the issue. I did tell them about @zaldeg‘s suggestion about the CPU but they were adamant it was this and they could not help with WordPress scripting.

    I was though on hold a lot of the time during the conversation and we have just tried the site on my manager’s computer and it seems to be working so we are cautiously going to leave it for the time being though I may leave this as unresolved just in case it crops up again.

    Thank you both for your suggestions and @esmi – I do agree with regards to the hosting so if it crops up again do you have any suggested hosting companies we could try?

    Although we do not personally endorse them, there are some hosts listed here. Also searching the forums using the keywords “host” or “hosting” may provide you with some suggestions.

    Ok thank you and and thank you for all of your help!

    I have been having this error as well. I also use Godaddy and every single internet search I have done on this issue brings me to other Godaddy users. I was having issues so Godaddy convinced me to try their deluxe hosting to try and solve those issues. I did a new install of WP and I have two different websites that I moved like this to deluxe hosting. Anyhow I have gotten this same error message occasionally on both sites which is what is so frustrating. Last time I got the error message I disabled all of my plugins and signed up for monitoring on Site24x7 to help me know when the issue was occurring since I can’t always trigger it right away.
    I was slowly reactivating my plugins about one per day and after activating my GARD adsense shortcode plugin I received the error again. So I disabled that plugin and found a different plugin to replace it. Now today I got the error message again. I have been checking links and can’t get it to occur right now.
    I am no expert but I am very doubtful that it is actually a plugin issue. It is very difficult to reproduce and the common element in all the postings I have found is Godaddy hosting. I would be very interested in knowing if anyone else with Godaddy hosting was able to get this issue resolved.

    I have been fighting this same issue, nearly positive it is a Godaddy hosting issue. Combination of their Shared Linux hosting\PHP\Wordpress. I speculate that not enough resources are allocated for php to run properly. I am going to experiment with a php.ini file with is the basic config file when php loads.

    I have found a solid work around if you are in a pinch. In the cPanel go to ‘Software/Service’ then PHP Process’ and then click ‘Kill Processes’ Button. It should at lease allow you to continue work.
    Good Luck!

    @austindmark Yes I do think it is a GoDaddy issue too because I also tried deactivating all the plug-ins and at first it appeared to work so I reactivated them one by one and then encountered the issue just like you did. I then uninstalled that particular plug-in and carried on with the rest of them. Then I left it overnight, came back and the issue suddenly came back again.

    At the moment though my manager has said to me to leave the issue for the time being but @bbett thank you for that I will give it a try and see what happens as it at least will mean I can work on the site without the issue getting in the way.

    Hi!

    I have been experiencing the same issue.

    In other sites I have seen they suggest to disable the option “APC” in the PHP config.

    And I think GoDaddy just added the option to config the PHP settings. In the CPanel look for “Select PHP version” and there you can disable the “APC” option.

    I’m trying that right now.

    Regards

    I’m also having this random error message about 5% of the time on my client site at http://www.i-cdt.com, on hold right now with GoDaddy tech support.

    I have 3 Go Daddy clients, only the one using Buddypress (63 members) has the issue. I tried every standard fix in the book, but because the site is live I’m unable to deactivate Buddypress long enough to wait and see if the error is not happening. Fortunately the error is rare, and almost always goes away as soon as I refresh. But It’s also completely random, can happen with members navigating the front end, or Admins the back end while doing just about anything. I can totally believe it’s a Go Daddy thing, in general, they probably have the worst hosting for a wordpress site.

    Hi All,

    Just wanted to share how I fix the issue. In the cpanel control panel, choose “Select PHP version”. Then I select “PHP Version 5.5”. Then click save.

    -Jess-

Viewing 15 replies - 16 through 30 (of 37 total)
  • The topic ‘Fatal Error: Cannot call overloaded function for non-object’ is closed to new replies.