WordPress.org

Support

Support » How-To and Troubleshooting » Fatal Error: Cannot call overloaded function for non-object

Fatal Error: Cannot call overloaded function for non-object

  • Hello Everyone,

    I have moved my WordPress site across onto a cPanel hosting plan on GoDaddy.

    Now however when I click around the site the page either loads up oddly or I get this error message:

    Fatal error: Cannot call overloaded function for non-object in /home/internetgenie/public_html/internet-genie.co.uk/wp-includes/class-wp.php on line 529

    This seems to happen whether it is on the front end or the back end of the site.

    Does anyone know what I would need to do to fix this.

    Many thanks in advance!

Viewing 15 replies - 1 through 15 (of 37 total)
  • esmi

    @esmi

    Forum Moderator

    Try re-uploading all files & folders – except the root wp-config.php & .htaccess files and the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    Hello @esmi,

    Thank you for your response.

    Just to clarify things do I need to download a new version of WordPress to my local machine then re-upload the files from this install onto the domain (apart from those three you stated).

    esmi

    @esmi

    Forum Moderator

    Yes – exactly that. Make sure that you delete the old copies of files & folder before uploading the new ones as over-writing doesn’t always work.

    Hi, I am encountering the same problem with my site, also hosted in godaddy. I am just surprised what happened because I just encounter this error yesterday morning. I am on version 3.9.1.

    Any help is greatly appreciated.

    Thanks,

    @internetgenie, did your problem resolved by re-uploading wordpress files & folders?

    Hello @esmi and @zaldeg,

    I have tried uploading the files and folders just now and it hasn’t worked as the fatal error is still coming up – Apologies for my late reply as I was working on another project yesterday.

    Is there anything else I could try please?

    esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the default theme automatically by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    @internetgenie,

    According to the one I talked from Godaddy, this is because we are already hitting the maximum CPU utilization. They only have allocated 512MB of RAM to us. and we me doing some installations and modification (because I am still on the initial golive phase), I may require a lot of memory usage. I told them that what we subscribed is the ultimate hosting plan with unlimited bandwidth and unlimited storage, then how come they limit us with the memory. it doesn’t make sense having an unlimited bandwidth if you have limited RAM because the more visitors you will have, the more resources will be needed. ANd they are asking me to upgrade to a managed wordpress plan. I told them, what????

    Anyway, I tried uninstalling some plugins that doesn’t really give more value to me and I replaced them with my own snippets. Seems it worked because I no longer see the errors in the afternoon until this time. I hope it won’t come up again tomorrow.

    That’s all for now.

    Thanks.

    @esmi,

    I have tried the two things you suggested and they are not working either.

    I did however when resetting the plug-ins and tried to log-in as the instructions stated on the link it flagged up errors about one of my plugins in particular. I then reset the plug-ins and de-activated this particular one but the error is still there.

    If you have got any other ideas though that will be great and thank you for your help so far!

    @zaldeg – that is interesting, I will try to contact GoDaddy myself about this now – thank you for letting me know!

    esmi

    @esmi

    Forum Moderator

    Can we see the site using the default Twenty Fourteen theme with all plugins deactivated?

    Yes I have put the site on the default theme with all the plug-ins deactivated.

    The URL is internet-genie.co.uk.

    esmi

    @esmi

    Forum Moderator

    I cannot see any problems with links on the site atm.

    Yes, it seems to work ok on some links but occurs randomly when the error message comes up.

    Just thinking now however I don’t think I tried it both with the theme and plug-ins deactivated together. I have just had a quick click a round and it seems ok for me to.

    esmi

    @esmi

    Forum Moderator

    I tried every link I could find on the site and they all worked for me. So it does seem like you have a theme or plugin issue. Without activating any plugins, try switching back to your old theme and check to see if the problem re-appears.

    I have reactivated Twenty Twelve now and gone through the site and as of yet I have not spotted the issue either (though when I said in my first post it either loads oddly or I get the error message what it looks like now is what I meant when it said loads oddly).

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘Fatal Error: Cannot call overloaded function for non-object’ is closed to new replies.