WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Fatal Error: Cannot call overloaded function for non-object (38 posts)

  1. internetgenie
    Member
    Posted 9 months ago #

    Hello Everyone,

    I have moved my WordPress site across onto a cPanel hosting plan on GoDaddy.

    Now however when I click around the site the page either loads up oddly or I get this error message:

    Fatal error: Cannot call overloaded function for non-object in /home/internetgenie/public_html/internet-genie.co.uk/wp-includes/class-wp.php on line 529

    This seems to happen whether it is on the front end or the back end of the site.

    Does anyone know what I would need to do to fix this.

    Many thanks in advance!

  2. esmi
    Forum Moderator
    Posted 9 months ago #

    Try re-uploading all files & folders - except the root wp-config.php & .htaccess files and the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. internetgenie
    Member
    Posted 9 months ago #

    Hello @esmi,

    Thank you for your response.

    Just to clarify things do I need to download a new version of WordPress to my local machine then re-upload the files from this install onto the domain (apart from those three you stated).

  4. esmi
    Forum Moderator
    Posted 9 months ago #

    Yes - exactly that. Make sure that you delete the old copies of files & folder before uploading the new ones as over-writing doesn't always work.

  5. zaldeg
    Member
    Posted 9 months ago #

    Hi, I am encountering the same problem with my site, also hosted in godaddy. I am just surprised what happened because I just encounter this error yesterday morning. I am on version 3.9.1.

    Any help is greatly appreciated.

    Thanks,

  6. zaldeg
    Member
    Posted 9 months ago #

    @internetgenie, did your problem resolved by re-uploading wordpress files & folders?

  7. internetgenie
    Member
    Posted 9 months ago #

    Hello @esmi and @zaldeg,

    I have tried uploading the files and folders just now and it hasn't worked as the fatal error is still coming up - Apologies for my late reply as I was working on another project yesterday.

    Is there anything else I could try please?

  8. esmi
    Forum Moderator
    Posted 9 months ago #

    Try:
    - switching to the default theme automatically by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

  9. zaldeg
    Member
    Posted 9 months ago #

    @internetgenie,

    According to the one I talked from Godaddy, this is because we are already hitting the maximum CPU utilization. They only have allocated 512MB of RAM to us. and we me doing some installations and modification (because I am still on the initial golive phase), I may require a lot of memory usage. I told them that what we subscribed is the ultimate hosting plan with unlimited bandwidth and unlimited storage, then how come they limit us with the memory. it doesn't make sense having an unlimited bandwidth if you have limited RAM because the more visitors you will have, the more resources will be needed. ANd they are asking me to upgrade to a managed wordpress plan. I told them, what????

    Anyway, I tried uninstalling some plugins that doesn't really give more value to me and I replaced them with my own snippets. Seems it worked because I no longer see the errors in the afternoon until this time. I hope it won't come up again tomorrow.

    That's all for now.

    Thanks.

  10. internetgenie
    Member
    Posted 9 months ago #

    @esmi,

    I have tried the two things you suggested and they are not working either.

    I did however when resetting the plug-ins and tried to log-in as the instructions stated on the link it flagged up errors about one of my plugins in particular. I then reset the plug-ins and de-activated this particular one but the error is still there.

    If you have got any other ideas though that will be great and thank you for your help so far!

    @zaldeg - that is interesting, I will try to contact GoDaddy myself about this now - thank you for letting me know!

  11. esmi
    Forum Moderator
    Posted 9 months ago #

    Can we see the site using the default Twenty Fourteen theme with all plugins deactivated?

  12. internetgenie
    Member
    Posted 9 months ago #

    Yes I have put the site on the default theme with all the plug-ins deactivated.

    The URL is internet-genie.co.uk.

  13. esmi
    Forum Moderator
    Posted 9 months ago #

    I cannot see any problems with links on the site atm.

  14. internetgenie
    Member
    Posted 9 months ago #

    Yes, it seems to work ok on some links but occurs randomly when the error message comes up.

    Just thinking now however I don't think I tried it both with the theme and plug-ins deactivated together. I have just had a quick click a round and it seems ok for me to.

  15. esmi
    Forum Moderator
    Posted 9 months ago #

    I tried every link I could find on the site and they all worked for me. So it does seem like you have a theme or plugin issue. Without activating any plugins, try switching back to your old theme and check to see if the problem re-appears.

  16. internetgenie
    Member
    Posted 9 months ago #

    I have reactivated Twenty Twelve now and gone through the site and as of yet I have not spotted the issue either (though when I said in my first post it either loads oddly or I get the error message what it looks like now is what I meant when it said loads oddly).

  17. esmi
    Forum Moderator
    Posted 9 months ago #

    Try re-activating the plugins one by one until you find the problematic plugin(s).

  18. zaldeg
    Member
    Posted 9 months ago #

    Hi @internetgenie,

    I visit your site and I got the error when I clicked Home.

    Have you tried calling Godaddy?

    How many active plugins do you have?

    Thanks,

  19. zaldeg
    Member
    Posted 9 months ago #

    My site is https://globaledgeconsultantsllc.com/. Let me know if you encounter the issue. It seems working now. I just uninstalled & delete some plugins. Something to do with godaddy hosting though because when I checked the status yesterday it says that we are on limited status for 24hrs.

    By the way, it is not something to do with Theme. I am on Catch Katmandu Theme, yet I encountered the same problem.

    Thanks,

    zaldeg

  20. internetgenie
    Member
    Posted 9 months ago #

    Apologies I have just come back now,

    @esmi - I have gone through the plug-ins now and activated them one-by-one, I did encounter an issue when I installed the Testimonials plug-in so I removed that but I had to leave it overnight and when I came back like @zaldeg stated the issue suddenly appeared again.

    @zaldeg - thank you for letting me know you spotted the issue on my site I have had a click around on the link above and I have not encountered the issue on yours. I also contacted GoDaddy and they did confirm to me that there is CPU limitations but the person I spoke to said Managed WordPress would not work and told me we will need to upgrade to a server for a higher cost (it seems when you speak to them you get different answers dependent on who it is). With regards to the plug-ins I did have more active but I have gone through and tried to reduce the plug-ins to as low as I can so there are currently 20 plug-ins on their active. At the moment I do not think I can replace any of these with code snippets as the site is one which I built for the company I work for as an apprentice and writing codes is not something at the moment I am comfortable with.

  21. esmi
    Forum Moderator
    Posted 9 months ago #

    it seems when you speak to them you get different answers dependent on who it is

    I'm afraid we see that a lot with GoDaddy. Very often, you have to really push to try and get decent answers to your questions. Have you considered moving to another host? I know I would.

  22. internetgenie
    Member
    Posted 9 months ago #

    /home/internetgenie/public_html/internet-genie.co.uk/wp-includes/class-wp.php on line 529

    I have just contacted GoDaddy now and I did get another suggestion from them. This time they followed the link mentioned in the error message to that file and that line.

    They told me it was a caching issue with WordPress and they tried it on three different computers and they apparently could not recreate the issue. I did tell them about @zaldeg's suggestion about the CPU but they were adamant it was this and they could not help with WordPress scripting.

    I was though on hold a lot of the time during the conversation and we have just tried the site on my manager's computer and it seems to be working so we are cautiously going to leave it for the time being though I may leave this as unresolved just in case it crops up again.

    Thank you both for your suggestions and @esmi - I do agree with regards to the hosting so if it crops up again do you have any suggested hosting companies we could try?

  23. esmi
    Forum Moderator
    Posted 9 months ago #

    Although we do not personally endorse them, there are some hosts listed here. Also searching the forums using the keywords "host" or "hosting" may provide you with some suggestions.

  24. internetgenie
    Member
    Posted 9 months ago #

    Ok thank you and and thank you for all of your help!

  25. Austindmark
    Member
    Posted 8 months ago #

    I have been having this error as well. I also use Godaddy and every single internet search I have done on this issue brings me to other Godaddy users. I was having issues so Godaddy convinced me to try their deluxe hosting to try and solve those issues. I did a new install of WP and I have two different websites that I moved like this to deluxe hosting. Anyhow I have gotten this same error message occasionally on both sites which is what is so frustrating. Last time I got the error message I disabled all of my plugins and signed up for monitoring on Site24x7 to help me know when the issue was occurring since I can't always trigger it right away.
    I was slowly reactivating my plugins about one per day and after activating my GARD adsense shortcode plugin I received the error again. So I disabled that plugin and found a different plugin to replace it. Now today I got the error message again. I have been checking links and can't get it to occur right now.
    I am no expert but I am very doubtful that it is actually a plugin issue. It is very difficult to reproduce and the common element in all the postings I have found is Godaddy hosting. I would be very interested in knowing if anyone else with Godaddy hosting was able to get this issue resolved.

  26. BBETT
    Member
    Posted 8 months ago #

    I have been fighting this same issue, nearly positive it is a Godaddy hosting issue. Combination of their Shared Linux hosting\PHP\Wordpress. I speculate that not enough resources are allocated for php to run properly. I am going to experiment with a php.ini file with is the basic config file when php loads.

    I have found a solid work around if you are in a pinch. In the cPanel go to 'Software/Service' then PHP Process' and then click 'Kill Processes' Button. It should at lease allow you to continue work.
    Good Luck!

  27. internetgenie
    Member
    Posted 8 months ago #

    @Austindmark Yes I do think it is a GoDaddy issue too because I also tried deactivating all the plug-ins and at first it appeared to work so I reactivated them one by one and then encountered the issue just like you did. I then uninstalled that particular plug-in and carried on with the rest of them. Then I left it overnight, came back and the issue suddenly came back again.

    At the moment though my manager has said to me to leave the issue for the time being but @BBETT thank you for that I will give it a try and see what happens as it at least will mean I can work on the site without the issue getting in the way.

  28. Geost
    Member
    Posted 8 months ago #

    Hi!

    I have been experiencing the same issue.

    In other sites I have seen they suggest to disable the option "APC" in the PHP config.

    And I think GoDaddy just added the option to config the PHP settings. In the CPanel look for "Select PHP version" and there you can disable the "APC" option.

    I'm trying that right now.

    Regards

  29. Daniel Payne
    Member
    Posted 8 months ago #

    I'm also having this random error message about 5% of the time on my client site at http://www.i-cdt.com, on hold right now with GoDaddy tech support.

  30. deepbevel
    Member
    Posted 7 months ago #

    I have 3 Go Daddy clients, only the one using Buddypress (63 members) has the issue. I tried every standard fix in the book, but because the site is live I'm unable to deactivate Buddypress long enough to wait and see if the error is not happening. Fortunately the error is rare, and almost always goes away as soon as I refresh. But It's also completely random, can happen with members navigating the front end, or Admins the back end while doing just about anything. I can totally believe it's a Go Daddy thing, in general, they probably have the worst hosting for a wordpress site.

Topic Closed

This topic has been closed to new replies.

About this Topic