Support » Plugin: MailPoet - emails and newsletters in WordPress » Fatal error, cannot activate

  • Resolved Oaz

    (@oaz)


    Hello, I had problems with previous version So I installed mailpoet some 3 weeks ago, and it seems okay.
    When I upgraded to lastest version, there were some message error and I had to desactivate it. Now I cannot activate it again, and I get this message :

    Fatal error: Uncaught PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘mairie_testlayer.wp_mailpoet_segments’ doesn’t exist in /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php:505 Stack trace: #0 /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php(505): PDOStatement->execute() #1 /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php(1909): ORM::_execute(‘SELECT * FROM `…’, Array, ‘default’) #2 /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php(687): ORM->_run() #3 /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/vendor/j4mie/paris/paris.php(145): ORM->find_one(NULL) #4 /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php(2269): ORMWrapper->find_one() #5 /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/lib/Models/Segment.php(123): ORM->__call in /home/clients/mairiea/prod/testlayers/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php on line 505

    I tried to desinstall and go back to mailpoet 3.27.0, but no luch I stilla have the same fatal error. More over, Whe I checked the website logs, here is what it says, again and again :

    [17-Jun-2019 17:53:14 UTC] Erreur de la base de données WordPress Table ‘mairie_testlayer.wp_mailpoet_newsletter_templates’ doesn’t exist pour la requête SHOW FULL COLUMNS FROM wp_mailpoet_newsletter_templates faite par do_action(‘activate_mailpoet/mailpoet.php’), WP_Hook->do_action, WP_Hook->apply_filters, MailPoet\Config\Initializer->runActivator, MailPoet\Config\Activator->activate, MailPoet\Config\Populator->up, array_map, MailPoet\Config\Populator->populate, MailPoet\Config\Populator->insertRow

    tried to clean up and install again 3 times, same result. May you help ?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.