Support » Installing WordPress » Fatal error: Call to undefined function wp_user_settings() in /home/content/h/o/

  • Resolved Thehousedog

    (@thehousedog)


    Hi,
    This is like my 3rd time trying to upgrade wordpress 2.6.3 to 2.7. So you can only imagine my frustration.

    I keep getting “Fatal error: Call to undefined function wp_user_settings() in /home/content/h/o/u/housedogjp/html/wp-admin/admin-header.php on line 14
    when I go to log into wp-admin” when I go to http://thehousedog.com/wp-admin

    I also get this “
    Fatal error: Call to undefined function post_class() in /home/content/h/o/u/housedogjp/html/wp-content/themes/default/index.php on line 15″ when i go to my blog at http://www.thehousedog.com

    I’ve uploaded all files in their proper folders. Can someone please help?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Out of curiousity, are you running PHP 5?

    (I assume that you actually uploaded all of the necessary files).

    Personally, I’m having problems with having the variable ABSPATH being set correctly.

    Yeah I’m using PHP 5.x

    It sucks 🙁

    Call to undefined function almost always means some files didn’t get uploaded

    Ok. This is just so frustrating. Is there anyway I can just upload 2.7 automatically. I use Godaddy and they only offer WordPress 2.6.3

    It sounds like the same problem as I have…
    Could it possibly be a general bug in WP 2.7?

    http://techie-buzz.com/wordpress-plugins/wordpress-automatic-upgrade-plugin-update.html

    I still think not all of the files were uploaded because of the “call to undefined function”

    I have the same error with the header…ive not yet seen the second error? Maybe yet to come?? Yelp!

    The referenced file it written the same on the worpress download as it is from GoDaddy… showing the same error. Maybe if some one who had a working site could take a look at let us know what it is supposed to say…

    Moderator kmessinger

    (@kmessinger)

    You all might re-read what samboll said.

    Hello everyone,

    I can’t log-in to my wp-admin.. I have this :

    Fatal error: Call to undefined function wp_user_settings() in /home/frankttm/public_html/wp-admin/admin-header.php on line 14

    I went back to upload a few times but it’s still the same. Wow.. a lot of headache for many members.. on this upgrading. I upgraded from V2.6.3 to V2.7.

    At first my website won’t load and I manage to get some answer in the forum but now my admin control panel won’t work & I can’t do posting.

    Thanks in advance, if anyone can advice.

    Regards,
    Frankie

    Fatal error: Call to undefined function

    This is the general error you get after an upgrade when you failed to upload ALL the files to your site.

    Do it again, and this time be absolutely certain that every single WordPress file is uploaded properly.

    I went back to upload a few times but it’s still the same.

    A wise man once told me that doing the same thing over and over and expecting different results is more or less the definition of insanity.

    You are doing something wrong. You need to figure out what that is.

    If you must know, the wp_user_settings function is in the wp-includes/functions.php file. So that suggests that you at least failed to upload that file properly, no? I’d suggest uploading them all, carefully, and trying to figure out where you’re going wrong.

    Hi Otto42,

    I went to do wp_user_settings function is in the wp-includes/functions.php file
    & it went in to Dashboard but I received the following message :

    Warning: Cannot modify header information – headers already sent by (output started at /home/frankttm/public_html/wp-includes/general-template.php:1819) in /home/frankttm/public_html/wp-includes/functions.php on line 698

    Warning: Cannot modify header information – headers already sent by (output started at /home/frankttm/public_html/wp-includes/general-template.php:1819) in /home/frankttm/public_html/wp-includes/functions.php on line 699

    I went to perform the steps but it didn’t work.. I also saw this in the Dashboard :

    Fatal error: Call to undefined function comment_class() in /home/frankttm/public_html/wp-admin/includes/dashboard.php on line 499

    Tried a few times on my FTP folder to correct it but it still didn’t work.

    Incase anybody can help again.. Thank you

    Regards,
    Frankie

    Hi Otto42,

    Looks like your suggestions worked. I went through some of the steps & finally uploaded the whole V2.7 folder again & now I managed to see the upgraded dashboard to click.

    I should be viewing the new dashboard now but the video & media is not fix as it does not load properly yet. I will browse through again to see what’s missing or what went wrong.

    Thanks a lot… & Merry X’mas..

    Cheers,
    Frankie

    Wow.. it’s totally new look & seems alright after I refreshed. Need to get use to it. Meantime, have to see how to move about.

    It has change to dropdown & with about 10 to 15mins of browsing around should get anyone find what they need to know & it’s quite similar except the placement of the icon change places.. cool..

    Regards,
    Frankie

    syncbox

    (@syncbox)

    I’m getting similar failed to load issues on trying to run the upgrade.php file– references to missing files that AREN’T missing… I can see them in the correct location on the remote server.

    But what I also see is a reference to php5— I thought the minimum requirements listed were php4.3 (or greater)?

    Fatal error: main() [function.require]: Failed opening required ‘ABSPATHwp-admin/includes/admin.php’ (include_path=’.;C:\php5\pear’) in E:\sites\www.kinematicscorps.com\wp-admin\upgrade.php on line 16

    Note that the wp-admin/includes/admin.php file IS there. If I load that file in the browser, it also pops an error:

    Fatal error: main() [function.require]: Failed opening required ‘ABSPATHwp-admin/includes/bookmark.php’ (include_path=’.;C:\php5\pear’) in E:\sites\www.kinematicscorps.com\wp-admin\includes\admin.php on line 10

    IS IT POSSIBLE that the www is a problem? I know that the host doesn’t have the site configured to load http://www.kinematicscorps.com... the site only loads without the www.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fatal error: Call to undefined function wp_user_settings() in /home/content/h/o/’ is closed to new replies.