Support » Plugin: Better Section Navigation Widget » Fatal Error: Call to undefined function is_plugin_active()

  • After updating the plugin to the most recent version, I get this error on all pages (including the admin dashboard)

    `
    HP message: PHP Fatal error: Uncaught Error: Call to undefined function is_plugin_active() in <<WORDPRESS PATH>>/wp-content/plugins/better-section-navigation/exclude-pages.php:271
    `

    For the moment I’ve commented out the require_once that includes exclude-pages.php but of course that’s not a permanent solution.

    PHP Version: 7.1.9
    WP Version: 4.9.8

Viewing 8 replies - 1 through 8 (of 8 total)
  • YES DO NOT UPDATE
    this version breaks WP with HTTP 500

    I’m getting a fatal error after upgrading as well. Running WP 4.9.8 and PHP 7.0.31.

    siteoctopus

    (@siteoctopus)

    After the most recent update the plugin is still broken. This time it causes an error when viewing the page/post editor:

    PHP message: PHP Fatal error: Uncaught ArgumentCountError: Too few arguments to function wp_kses(), 1 passed in /WORDPRESS PATH/wp-content/plugins/better-section-navigation/exclude-pages.php on line 208 and at least 2 expected in /WORDPRESS PATH/wp-includes/kses.php:526

    Again, this can be fixed by commenting require_once 'exclude-pages.php';

    • This reply was modified 8 months ago by  siteoctopus.

    Hi there! Sorry for the delay.

    We fixed the first issue (“Call to undefined function is_plugin_active()”) earlier in August, and then fixed the second one (“Too few arguments to function wp_kses()”) on 8/24, so everything should be working now.

    I don’t know exactly why there were so many issues in that file, but the wp_kses() issue is related to a change in PHP 7.2: that same error used to be non-fatal, and so it could easily fly under the radar during development, but the PHP team has decided to crack down on it in the newest release of PHP.

    audioscavenger

    (@audioscavenger)

    thank you! I will give it a try in my testing environment.

    FYI, this is NOT related to PHP 7.2 as I have the issue with PHP 7.0.32

    Hi @audioscavenger

    Just checking to see how things went on your testing environment. Let us know if there are any errors we should investigate — and feel free to email support@cshp.co if you have additional information to share about the issue.

    Thanks!

    audioscavenger

    (@audioscavenger)

    sorry for late reply

    thank you the error is gone
    you can close the thread

    Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.