WordPress.org

Support

Support » How-To and Troubleshooting » Fatal error: Call to undefined function: is_admin() “What the

Fatal error: Call to undefined function: is_admin() “What the

  • I posted a problem a couple of hours ago about not being able to update, but it now has gone more serious.
    when I type in to my site, http://www.salesd.com the following line comes up,

    Fatal error: Call to undefined function: is_admin() in /home/www/salesd.com/wp-includes/vars.php on line 16

    Can you tell me what to do, I think I have to go into some file, (Which one) and change something on line 16.

    Can you point me in the right direction. I can not get into the admin section so I have to do it through the control panel.

    Please help, to much work gone into this site, to lose it.

Viewing 15 replies - 16 through 30 (of 30 total)
  • WOW be very careful on manually updating to fix this.

    It just wiped my whole database. luckily was a fresh test site or I would be really mad.

    BACKUP THE DATABASE FIRST!!!

    ricoslist
    Member

    @ricoslist

    Yes, absolutely back up the database first – if i hadn’t, i’d be crying right now.

    My webhost doesn’t limit the mem setting; and i’ve happily run wp-2.7 – 2.9b with the mem limit set at 128; worked just fine.

    The really strange aspect to me is my add-on domain http://www.websitenamehere.com *requires* more than 32mb, and is actually running fine with a mem limit = 128 in the wp-settings.php in its directory (for http://www.websitenamehere.com) – I keep waiting for the add on site to break because of mem limit=32 in the primary domain directory being the only setting that works; and yes, I’ve tried 64m, 92m, 128m – anything over 32m in the primary wp-settings.php file breaks that site, and all the sub sites.

    I think the whole issue is the auto-upgrade. Like the error in 2.8.3

    I run 40 wp sites and have never had to adjust any mem limit. The only time I see a mem limit uissue is when building a sitemap on a huge site and that plugin needs more to finish.

    The only reason why I even triggered this error was the theme was trying to import a video, so depends on your theme and plugins.

    ricoslist
    Member

    @ricoslist

    ok. i just now manually reinstalled *everything* yet again – still have the same issue re: any mem limit over 32m in the primary domain folder’s wp-settings.php file breaks all of my wordpress sites – including the primary domain.

    if this is a bug – what is the correct escalation path to alert the dev team to this issue?

    thank you….!

    This function is in wp_settings.php. I had the same problem because I hadn’t copied that file over. As soon as I did, it fixed it..

    [signature removed]

    mandyjill
    Member

    @mandyjill

    Thanks Portent. I had my blog hacked and re-uploaded the wp-includes file but still had the same error thrown as the original poster. So I followed your advice and uploaded the wp_settings.php file for ver. 2.9 and now I’m back online (hopefully for good….)

    ya the wp-settings.php file.
    just wiped my whole site that I just spent 3 hours building.

    WP 2.9 and upgrade really sucks, they really need to fix this

    antiresearch
    Member

    @antiresearch

    And I just wiped mine. That was some hard work there.

    Please, please fix this.

    superflippy
    Member

    @superflippy

    I just managed to get myself out of this problem. Still not sure why it worked, but here’s what I did:

    While using auto-upgrade, I got the “Fatal error: Call to undefined function: is_admin()” message.
    Tried to roll back, but couldn’t get my backups to unzip properly. So…
    I went back to the error page and hit my browser’s back button.
    Instead of the previous upgrade page, I got a page with an “upgrade your database” button. I clicked the button.
    It took me back to my admin pages with a warning at the top to get rid of extra files from an old installation. I clicked on the link to do that.
    The upgrade page reloaded, said I was done. And my blog seems to be working again, and upgraded!

    antistandard
    Member

    @antistandard

    Hey everyone,

    I had the same problem and fixed it this way:

    1. I get the error about memory limit when I am trying to auto upgrade a commerce plugin.

    2. I went into wp-settings.php and changed 32 to 64

    3. i get the ‘Fatal error: Call to undefined function: is_admin()’ error and I can’t get into the site on any page and the sky goes dark and I hate wordpress.

    4. I read this thread and decide to not get too dramatic just yet, so I manually download wp 2.9.1 and copy across the files : wp-setings.php and vars.php to my site that is down.

    5. Now it is back up and running again. So I recommend just trying this first before you backup databases, content folders etc.

    Thanks for this thread, it helped me out. Help bloggers rule.

    WordPress dev team – dudes, seriously, how can you release even such a minor update and have it break heaps of peoples sites. It makes us loose faith. Less updates, more stability I say. WordPress is flippn awesome but when something goes wrong the whole wordpress structure goes to hell. Less updates, more stability please.

    Thank you

    solesirius
    Member

    @solesirius

    I just had the same error, and antistandard solution worked for me. Now that my site is up and running again i ran into another problem. None of the images i added to my post are loading. any idea why?

    I did what others have said to do on this page – I copied the original wp-content folder and wp-config.php and installed wordpress (2.9.1) onto my computer. I uploaded the new installation of wordpress onto my domain and then copied the original content folder and wp-config.php file… my site ran, but it was blank. Should I have backed up the database, too? I’m guessing that’s what the problem is.
    Sorry if I’m an annoying newb…

    I did what Antistandard suggested and got my site back up (says I’m running 2.9.2 even though I’m using those two files from 2.9.1.

    Specifically, I did:

    4. ….. I manually download wp 2.9.1 and copy across the files : wp-setings.php and vars.php to my site that is down.

    5. Now it is back up and running again. So I recommend just trying this first before you backup databases, content folders etc.

    Thanks,

    [signature removed]

    alanjcastonguay
    Member

    @alanjcastonguay

    I hit this same issue while upgrading from 2.8.ish to 2.9.2.

    Problem was specifically a bad upload of wp-settings.php — the old version of the file was still on the FTP server, and did not contain a definition of is_admin(). The new version of that file does have is_admin() defined.

    very helpful! I solved the problem. thanks wordpress community!

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘Fatal error: Call to undefined function: is_admin() “What the’ is closed to new replies.