Support » Fixing WordPress » Fatal error: Call to undefined function: is_admin() “What the

  • I posted a problem a couple of hours ago about not being able to update, but it now has gone more serious.
    when I type in to my site, the following line comes up,

    Fatal error: Call to undefined function: is_admin() in /home/www/ on line 16

    Can you tell me what to do, I think I have to go into some file, (Which one) and change something on line 16.

    Can you point me in the right direction. I can not get into the admin section so I have to do it through the control panel.

    Please help, to much work gone into this site, to lose it.

Viewing 15 replies - 1 through 15 (of 30 total)
  • Relax. Deep breath.

    Use FTP and follow the manual upgrade process. Read carefully and take it slow if you’ve never done it before.

    But what about my site which is now gone. Is all my months of work gone.

    Dont mention back up my hosting company said they back up everything, and now they are stalling.

    Don’t panic. The posts themselves will be stored in your sql database. Images and any other media that you’ve upload should be in your wp-content folder, along with your plugins and themes. As long as you leave all of those (and your wp-config.php file) well alone, you should be fine.

    Or just wait and see what your host comes back with.

    Are you saying to manually update the script. Will the problem not be still there. Will, what ever line they tell me, I having trouble with, will I not still have trouble with that line.
    Do I not have to clear something from it

    Yes, manually reupload the core WordPress files. It sounds like it didn’t happen properly first time with the automatic upgrade, so best just to do it again yourself to fix whatever files are missing/corrupted/whatever from the first attempt.

    If it can help, B1gft, I’ll make it clear :

    – you only need to preserve the /wp-content/ and /wp-config.php folder and file
    – everything else can be removed and reuploaded as many times as you wish
    – your data isn’t at risk, it is safely stored elsewhere, in your host’s database server

    This is what my host said to me, I dont know why they could not put the back up copy on, they said it did not fix the problem.

    Once you download that,(wordpress) uzip it, access the wp-content/themes and remove all themes folders. Then return to the main directory, select all files and folders and upload them to your site using ftp.
    If you are unable to handle this, I would suggest you to hire someone to help you.

    Do you agree with what they are saying.

    I had the same problem as OP.

    I backed everything up and did the manual install and Im still getting the same error mentioned above.

    What’s going on guys?

    *follow up

    OK crisis averted…I rolled back to 2.86 and I’m back online. Since I’m not the only one with this problem I have to recommend against updating.

    Jriggs did you do excactly as my host said to do, did you leave out the
    themes folder

    No. I downloaded 2.8.6 from here
    and copied my original config, theme, plugin and settings files and my site started working again.

    I work at a webhosting company and had a customer with this issue, it popped up shortly after upgrading to 2.9.

    Not sure what caused it, but a manual reinstall, as previously instructed, and using the latest stable(2.9), fixed the issue.

    At first I tried just copying the vars.php and that was no help.

    So, here’s pretty much exactly what I did:

    Moved wp-content and wp-config.php to a safe location. Unzipped the obtained from into their public_html, copied wp-config.php and wp-content back over into public_html as well.

    Once that was done, the site started working as it should. YMMV.

    I also encountered same problem

    and Manual upload of files solved the problem, and I am upgraded to 2.9 now….

    Do I have to delete the old wordpress files, before I upload the new files.
    The problem is I dont want to lose any thing on the site.

    I think this is a bigger issue.

    A manual (re)install does solve this error message, but NOT if running multiple wordpress installs as individual domains, but as a sub-domain of a primary web hosting account.

    I run wordpress on my blog, which is its own domain (

    My web host allows me to run other domains ( under the same hosting accounting account, although officially they are subdomains of my primary account (

    Orginally I used simplescript to upgrade all of my wordpress installs; the primary account domain ( upgraded fine, no breaks; but auto-upgrading fronm 2.9.b to 2.9 repeatedly resulted in the error “Call to undefined function is_admin() in /home/blognamehere/public_html/wp-includes/vars.php on line 16.”

    not that excited about doing a manual install, i instead decided to do a totally new, clean install of 2.9 in’s directory; clean install was fine until i imported orginal mysql db into new install/db – once again could not shake the error message “Call to undefined function is_admin() in /home/blognamehere/public_html/wp-includes/vars.php on line 16.”

    i then followed in painstaking detail the instructions on this thread to manually upgrade; including as usual changing in that directory the memory limit in wp-settings.php (from 32 mb to 128 mb).

    result: is now running 2.9 and seems to run fine.

    HOWEVER – that then broke the already upgraded (and working fine) 2.9 wordpress install in my primary domain (, with the same error message: “Call to undefined function is_admin() in /home/blognamehere/public_html/wp-includes/vars.php on line 16.”

    i then manually upgraded; which now works ONLY if the wp-settings.php memmory limit in that (primary) directory remains at 32 mb; and breaks again if that wp-settings memory limit is increased beyond 32 mb.

    Prior to the upgrade from 2.9b to 2.9, the wp-settings.php file in all my domain directories (primary, and add on domains running as subs of the primary) were set to a memory limit of 128 mb memory – and all ran fine.

    Unfortunately I need to be able to set all wp-settings.php memory limits to 128 mb in order to maintain functionality of each wordpress installs’ individual plugins.

    Any suggestions/thoughts, and/or is there a workaround for the apparent restrictions on increasing the memory limit above 32mb in the primary wp-settings.php directory?

    Thank you.

    Deff a 2.9 issue.

    The mem limit sounds like that could be the issue and is a real bug. Just started a fresh install as test site and no prob with 2.8.6 and upgraded and used the built in video add function built into the theme and got the error.

    Guess not good idea to upgrade yet.

    OH, depends on your host on the mem limit if you can raise it. Most shared hosts have it set to 64mg limit. You can see what your is in you php.ini file. If you have cpanel use the php.ini quick config icon to see what its set to, more then likely you wont be able to raise it.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Fatal error: Call to undefined function: is_admin() “What the’ is closed to new replies.