WordPress.org

Support

Support » Plugins and Hacks » Single Post Template » Fatal error: Call to undefined function get_post_templates

Fatal error: Call to undefined function get_post_templates

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same thing.

    Been running the plugin forever, and just upgraded, and my site crashed. I tried to upload an old version (form a backup) of the post-template.php file, and that wouldn’t work – I get a Database error.

    I deactivated the plugin, so I can’t tell you exactly what the error is, but some syntax error, I think on line 88.

    I deactivated version 1.4 of this plugin (by renaming it) and uploaded the previous version (which I had still installed on a dev site), and it’s back to functioning properly for now. Waiting for 1.41!

    Hello
    Same problem, can you please provide the old version so i can put it back on, my site is in chaos right now.

    Thanks Daveregg 🙂

    This older version is not supported with the latest wordpress. is there any way around to make it work ?

    Based on the timing of this, I’m assuming the plugin developer posted the update and went to sleep. Hopefully in the next couple hours he’ll be up and check his email.

    Guess you are right, lets see 🙂

    The plugin is now at 1.43 as of an hour and a half ago. Does this work for everyone now?

    Hey Dave

    As per one of the other threads on this right now:
    link

    No .. it’s still not working for me. I ran the upgrade on one of the blogs, and while the old post I’ve used the plugin for is now working correctly, when I try to write a new post, I do not get an option to select which of the post templates I want to choose from – meaning it’ll just default to the single.php file.

    It’s not a big deal for me on that blog, but my other blog has lots of differently style posts, and I use that function a lot; so I haven’t upgraded it and am still on the old version for that site.

    Cheers

    Carl

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Fatal error: Call to undefined function get_post_templates’ is closed to new replies.
Skip to toolbar