WordPress.org

Support

Support » Plugins and Hacks » underConstruction » Fatal error: Call to undefined function get_editable_roles()

Fatal error: Call to undefined function get_editable_roles()

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    Give this a try.

    1. Using FTP or whatever filemanagement tools your host has provided you with navigate to the wp-content/plugins directory.
    2. Once there locate and delete the underconstruction directory. Just that one directory and nothing else.
    3. Try and re-login to your WordPress dashboard.

    I get the same error.

    You aren’t actually locked out of your admin at this point. Just edit the URL in your browser and change wp-login.php to wp-admin. No need to delete the plugin.

    Hi mkbonline

    I got the same error. But this is how it got solved.
    I activated this plugin..Then make the plugin on.
    and when I logged out from my actual dashboard and again went to login my site like…

    http://www.abc.com/wp-admin

    and tried to login, it gave me the same error and the page currently it was showing http://www.abc.com/wp-login.php

    so i opened a new window and typed the URL again http://www.abc.com/wp-admin

    and it took me directly to my dashboard…
    Hope this trick helps you.

    This is actually shouldn’t happen, but its great plugin …thank you.

    Hi everybody,

    yes, it is. In this way I came into the admin area, too and without entering a password. (shock!) But the problem comes back exactly. If you have logged out and log in again, comes the same error message:

    Fatal error: Call to undefined function get_editable_roles() in /home/XXXX/public_html/wp-content/plugins/underconstruction/underConstruction.php on line 135

    This is a serious bug.
    What now?

    I get the same problem. The workaround is to edit the URL and change it to wp-admin. But nonetheless the plugin needs to be fixed.

    Plugin dev could take a clue from the fix used for a similar problem with Jetpack:

    http://plugins.trac.wordpress.org/changeset/706924

    Got the same problem in all my WordPress sites now…

    Any update? Any fix?

    Thanks!!!

    new version, 1.11 just fixed this for me. thank you!

    Also for me, the login works again now without the error.

    But something is new since the update 1.11:
    I am not right away – as usual – straight into the admin area, but in the blog preview. I have to click “Dashboard” to get into the admin area. That’s new.
    Has anyone else this?

    No, 1.11 is working without error for me and going right to the dashboard. Are you logging in by going to “<your-site-url>/wp-admin”?

    Hi Robert,
    I take the same login as I do for 3 years. I think it’s the standard-login.
    “mysite.com/wp-login-php”.
    I have always arrived directly in the admin area.
    Then the login problem came with version 1.10. And since 1:11 this now.
    Strange.

    Strange indeed – when I use <mysite.com>/wp-login.php it takes me right to the dashboard.

    Exactly, so it was with me always. So far.
    I have not changed anything. Only the update to 1:11.
    We’ll see if this has changed at someone else in this way.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Fatal error: Call to undefined function get_editable_roles()’ is closed to new replies.
Skip to toolbar