WordPress.org

Support

Support » Multisite » [Resolved] Fatal Error: Call to function – Multisite

[Resolved] Fatal Error: Call to function – Multisite

  • I am getting the error – Fatal error: Call to undefined function get_the_post_thumbnail() in /home/warrior/public_html/wp-content/themes/earth-warrior/page.php on line 18

    i removed line 18 to see if it came back but it just came up with the same message but for a different function. The function files in wp-includes i haven’t touch and the default themes seem to be working fine so that says that the issue is with my custom theme.

    downloaded my custom theme from the ftp and installed it on a local MAMP installation – works perfect…

    can someone suggest a course of action/investigation.

    thanks

    http://earth-warrior.com/ice-warrior/

Viewing 11 replies - 1 through 11 (of 11 total)
  • ps. have tried deactivating all plugins but still get the error.

    esmi
    Forum Moderator

    @esmi

    Are you absolutely sure that you are using WordPress 3.3.1?

    yeah I am.

    esmi
    Forum Moderator

    @esmi

    Try re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    ok, will get back to you as to how it goes.

    FWIW, just because something works perfectly in Localhost doesn’t always mean it’ll work out in the wild.

    You should also make 100% sure you have the whole theme uploaded, and that it doesn’t have any goofy calls to localhost in it.

    Has been working fine in the wild for the last 3 weeks while it underwent testing and content submission. Just tonight that it came up with that error for no logical reason (no updates etc)

    mmm after re adding all the files I am getting the hosts 404 page when trying to access the network sites but i can get to the respective dashboards?

    gaah no help wordpress reinstalled and the same issue

    my guess is somehow it’s not calling twenty eleven. in localhost i get the twenty eleven theme options with my custom theme, online i don’t.

    this was the problem – a stray character in the calling of twenty eleven in the child themes css, doesn’t explain why it worked locally but sorted now

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Fatal Error: Call to function – Multisite’ is closed to new replies.